aboutsummaryrefslogtreecommitdiff
path: root/graphics/jpeg-turbo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/jpeg-turbo/Makefile')
-rw-r--r--graphics/jpeg-turbo/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/graphics/jpeg-turbo/Makefile b/graphics/jpeg-turbo/Makefile
index 10c8e6530b41..b1b8418d0de3 100644
--- a/graphics/jpeg-turbo/Makefile
+++ b/graphics/jpeg-turbo/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= jpeg-turbo
-PORTVERSION= 1.3.0
-PORTREVISION?= 2
+PORTVERSION= 1.3.1
CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
+MASTER_SITES= SF/lib${PORTNAME}/${PORTVERSION}
DISTNAME= lib${PORTNAME}-${PORTVERSION}
MAINTAINER= bytestore@yandex.ru
@@ -16,20 +15,16 @@ BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
ONLY_FOR_ARCHS= amd64 i386
USES= libtool
GNU_CONFIGURE= yes
-CONFIGURE_ENV= SO_MAJOR_VERSION=${SOVERSION}
+CONFIGURE_ENV= SO_MAJOR_VERSION=62
CONFIGURE_ARGS= --with-jpeg8
USE_LDCONFIG= yes
ALL_TARGET= test
INSTALL_TARGET= install-strip
-PLIST_SUB= SOVERSION=${SOVERSION}
PORTDOCS= *
PORTEXAMPLES= *
-# chase graphics/jpeg
-SOVERSION= 11
-
-OPTIONS_DEFINE= DOCS EXAMPLES PIC
+OPTIONS_DEFINE= DOCS EXAMPLES PIC
PIC_DESC= Static library with PIC (required for VirtualGL)
DOCS_MAKE_ARGS= docdir="${DOCSDIR}"
@@ -43,9 +38,13 @@ PIC_CONFIGURE_ON= --with-pic
.if defined(SLAVE_PORT)
PLIST_SUB+= JPEG="@comment " LIBTURBOJPEG=""
.else
+CONFIGURE_ARGS+= --program-suffix=-turbo
PLIST_SUB+= JPEG="" LIBTURBOJPEG="@comment "
-CONFLICTS_INSTALL= jpeg-[0-9]*
+#CONFLICTS_INSTALL= jpeg-[0-9]*
CONFIGURE_ARGS+=--without-libturbojpeg
+
+post-install:
+ @${ECHO_CMD} "libjpeg.so.11 libjpeg.so.62" >> ${STAGEDIR}${PREFIX}/etc/libmap.d/${PORTNAME}.conf
.endif
.include <bsd.port.mk>