aboutsummaryrefslogtreecommitdiff
path: root/graphics/kf5-kimageformats
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/kf5-kimageformats')
-rw-r--r--graphics/kf5-kimageformats/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/graphics/kf5-kimageformats/Makefile b/graphics/kf5-kimageformats/Makefile
index b47210e93f3e..5994bc70853e 100644
--- a/graphics/kf5-kimageformats/Makefile
+++ b/graphics/kf5-kimageformats/Makefile
@@ -1,17 +1,20 @@
PORTNAME= kimageformats
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
COMMENT= KF5 library providing support for additional image formats
-LIB_DEPENDS= libHalf.so:graphics/ilmbase
+LIB_DEPENDS= libImath.so:math/Imath
USES= cmake compiler:c++11-lib kde:5 pkgconfig qt:5 tar:xz
USE_KDE= archive ecm
USE_QT= core gui printsupport widgets \
buildtools_build qmake_build
+CFLAGS+= -I${LOCALBASE}/include/Imath
+
OPTIONS_DEFINE= AVIF OPENEXR
OPTIONS_DEFAULT= AVIF OPENEXR
OPTIONS_SUB= yes
@@ -20,7 +23,11 @@ AVIF_DESC= AV1 Image File Format via libavif
AVIF_LIB_DEPENDS= libavif.so:graphics/libavif
AVIF_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_libavif
-OPENEXR_LIB_DEPENDS= libIlmImf.so:graphics/openexr
+OPENEXR_LIB_DEPENDS= libOpenEXR.so:graphics/openexr
OPENEXR_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_OpenEXR
+post-patch:
+ ${REINPLACE_CMD} s,Imf::Int64,uint64_t, \
+ ${WRKSRC}/src/imageformats/exr.cpp
+
.include <bsd.port.mk>