aboutsummaryrefslogtreecommitdiff
path: root/graphics/kimagemapeditor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/kimagemapeditor/Makefile')
-rw-r--r--graphics/kimagemapeditor/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/graphics/kimagemapeditor/Makefile b/graphics/kimagemapeditor/Makefile
index 29232fa8a8a6..1eff2b4338a0 100644
--- a/graphics/kimagemapeditor/Makefile
+++ b/graphics/kimagemapeditor/Makefile
@@ -16,10 +16,14 @@ USE_BZIP2= yes
USE_KDELIBS_VER= 3
USE_GMAKE= yes
USE_LIBTOOL= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=
CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+pre-configure:
+ ${REINPLACE_CMD} -e 's|-pedantic ||g' ${WRKSRC}/configure
+
.include <bsd.port.mk>