aboutsummaryrefslogtreecommitdiff
path: root/graphics/linux-c7-sdl_ttf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/linux-c7-sdl_ttf/Makefile')
-rw-r--r--graphics/linux-c7-sdl_ttf/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/graphics/linux-c7-sdl_ttf/Makefile b/graphics/linux-c7-sdl_ttf/Makefile
new file mode 100644
index 000000000000..243604ba2e81
--- /dev/null
+++ b/graphics/linux-c7-sdl_ttf/Makefile
@@ -0,0 +1,28 @@
+# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
+# $FreeBSD$
+
+PORTNAME= sdl_ttf
+PORTVERSION= 2.0.11
+CATEGORIES= graphics linux
+MASTER_SITES= EPEL7/s
+DISTNAME= ${LINUX_NAME}-${PORTVERSION}-${RPMVERSION}
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Simple library to load True Type Fonts as SDL interfaces (Linux CentOS ${LINUX_DIST_VER})
+
+CONFLICTS= linux-f10-${PORTNAME}-[0-9]* linux-c6-${PORTNAME}-[0-9]*
+
+LINUX_NAME= SDL_ttf
+ONLY_FOR_ARCHS= amd64
+RPMVERSION= 6.el7
+USES= linux:c7
+USE_LDCONFIG= yes
+USE_LINUX= jpeg png sdl12 tiff
+USE_LINUX_RPM= yes
+
+DOCSDIR= ${PREFIX}/usr/share/doc/${LINUX_NAME}-${PORTVERSION}
+PORTDOCS= CHANGES COPYING README
+
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>