aboutsummaryrefslogtreecommitdiff
path: root/graphics/mandelbulber/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/mandelbulber/Makefile')
-rw-r--r--graphics/mandelbulber/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/graphics/mandelbulber/Makefile b/graphics/mandelbulber/Makefile
new file mode 100644
index 000000000000..1e4947849e90
--- /dev/null
+++ b/graphics/mandelbulber/Makefile
@@ -0,0 +1,50 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mandelbulber
+DISTVERSION= 1.13-1
+CATEGORIES= graphics
+MASTER_SITES= SF/${PORTNAME}
+DISTNAME= ${PORTNAME}${DISTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= 3D Mandelbrot fractal renderer
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GMAKE= yes
+USE_GNOME= glib20 gtk20
+BUILD_WRKSRC= ${WRKSRC}/makefiles
+MAKEFILE= makefile
+CXXFLAGS+= -DSHARED_DIR=\\\"${DATADIR}\\\"
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= bin/${PORTNAME} share/applications/${PORTNAME}.desktop
+PLIST_DIRSTRY= share/applications
+
+PORTDOCS= README NEWS
+PORTDATA= *
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/mandelbulber|${DATADIR}|' \
+ ${WRKSRC}/${PORTNAME}.desktop
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications
+.if !defined(NOPORTDATA)
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC}/usr/share && ${COPYTREE_SHARE} '*' ${DATADIR}/
+.endif
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>