aboutsummaryrefslogtreecommitdiff
path: root/graphics/optar/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/optar/Makefile')
-rw-r--r--graphics/optar/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/graphics/optar/Makefile b/graphics/optar/Makefile
index a2f0315b002d..e7324587ab73 100644
--- a/graphics/optar/Makefile
+++ b/graphics/optar/Makefile
@@ -2,27 +2,24 @@
# $FreeBSD$
PORTNAME= optar
-PORTVERSION= 1.0
-PORTREVISION= 5
+PORTVERSION= 2015.02.09
CATEGORIES= graphics
MASTER_SITES= http://ronja.twibright.com/
-DISTFILES= optar.tgz
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Tool for encoding data on paper
LICENSE= GPLv2
-
-BROKEN= Checksum and size mismatch
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2015-11-26
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
WRKSRC= ${WRKDIR}/optar_dist
-USES= gmake
+USES= gmake tar:tgz
PLIST_FILES= bin/optar bin/unoptar bin/pgm2ps
@@ -30,8 +27,8 @@ post-patch:
@${REINPLACE_CMD} -e \
's|^CFLAGS|#CFLAGS| ; \
s|gcc |$$(CC) | ; \
- s|-I/usr/local/include/libpng|`libpng-config --I_opts`| ; \
- s|-L/usr/local/lib|`libpng-config --L_opts`|' \
+ s|-I/usr/local/include/libpng|$$$$(libpng-config --I_opts)| ; \
+ s|-L/usr/local/lib|$$$$(libpng-config --L_opts)|' \
${WRKSRC}/Makefile
do-install: