aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Graphics-Primitive/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/p5-Graphics-Primitive/Makefile')
-rw-r--r--graphics/p5-Graphics-Primitive/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/graphics/p5-Graphics-Primitive/Makefile b/graphics/p5-Graphics-Primitive/Makefile
index 21a8e7b39ec9..e2738b136c91 100644
--- a/graphics/p5-Graphics-Primitive/Makefile
+++ b/graphics/p5-Graphics-Primitive/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Graphics-Primitive
-PORTVERSION= 0.45
+PORTVERSION= 0.46
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../by-authors/id/G/GP/GPHAT
@@ -15,14 +15,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Device and library agnostic graphic primitives
-BUILD_DEPENDS= p5-Geometry-Primitive>=0.16:${PORTSDIR}/graphics/p5-Geometry-Primitive \
+RUN_DEPENDS= p5-Forest>=0.06:${PORTSDIR}/devel/p5-Forest \
+ p5-Geometry-Primitive>=0.16:${PORTSDIR}/graphics/p5-Geometry-Primitive \
p5-Graphics-Color>=0.20:${PORTSDIR}/graphics/p5-Graphics-Color \
+ p5-JSON-Any>=1.22:${PORTSDIR}/converters/p5-JSON-Any \
p5-Moose>=0.79:${PORTSDIR}/devel/p5-Moose \
- p5-MooseX-Clone>=0.04:${PORTSDIR}/devel/p5-MooseX-Clone \
- p5-MooseX-AttributeHelpers>=0.17:${PORTSDIR}/devel/p5-MooseX-AttributeHelpers \
- p5-MooseX-Storage>=0.17:${PORTSDIR}/devel/p5-MooseX-Storage \
- p5-Forest>=0.06:${PORTSDIR}/devel/p5-Forest
-RUN_DEPENDS= ${BUILD_DEPENDS}
+ p5-MooseX-AttributeHelpers>=0.17:${PORTSDIR}/devel/p5-MooseX-AttributeHelpers \
+ p5-MooseX-Clone>=0.04:${PORTSDIR}/devel/p5-MooseX-Clone \
+ p5-MooseX-Storage>=0.17:${PORTSDIR}/devel/p5-MooseX-Storage
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= YES