aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-PGPLOT/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/p5-PGPLOT/Makefile')
-rw-r--r--graphics/p5-PGPLOT/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/graphics/p5-PGPLOT/Makefile b/graphics/p5-PGPLOT/Makefile
index f44c85b38b04..57305a955f67 100644
--- a/graphics/p5-PGPLOT/Makefile
+++ b/graphics/p5-PGPLOT/Makefile
@@ -33,4 +33,10 @@ post-install:
cd ${WRKSRC}/ && ${INSTALL_DATA} LICENSE test* ${EXAMPLESDIR}/
.endif
+.if defined(MAINTAINER_MODE) && !defined(BATCH)
+check regression-test test: build
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} \
+ ${_MAKE_JOBS} ${MAKE_ARGS} test
+.endif
+
.include <bsd.port.mk>