aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-cartopy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-cartopy/Makefile')
-rw-r--r--graphics/py-cartopy/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/graphics/py-cartopy/Makefile b/graphics/py-cartopy/Makefile
new file mode 100644
index 000000000000..6366f7ba24c1
--- /dev/null
+++ b/graphics/py-cartopy/Makefile
@@ -0,0 +1,30 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cartopy
+PORTVERSION= 0.16.0
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Cartopy-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Cartographic library with Matplotlib support for visualisation
+
+LICENSE= LGPL3+
+LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
+
+BUILD_DEPENDS= geos>-3.3.3:graphics/geos \
+ proj>=4.9.0:graphics/proj \
+ ${PYNUMPY}
+LIB_DEPENDS= libgeos.so:graphics/geos \
+ libproj.so:graphics/proj
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}pyshp>=1.1.4:devel/py-pyshp@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Shapely>=1.5.6:devel/py-shapely@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.3.0:devel/py-six@${FLAVOR}
+
+USE_PYTHON= autoplist concurrent cython distutils
+USES= python
+
+.include <bsd.port.mk>