aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-sorl-thumbnail/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-sorl-thumbnail/Makefile')
-rw-r--r--graphics/py-sorl-thumbnail/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/graphics/py-sorl-thumbnail/Makefile b/graphics/py-sorl-thumbnail/Makefile
index 5fbb46d00de1..bf7e6e4e3d88 100644
--- a/graphics/py-sorl-thumbnail/Makefile
+++ b/graphics/py-sorl-thumbnail/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sorl-thumbnail
PORTVERSION= 12.4.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -34,7 +34,6 @@ DOCS_VARS= PYDISTUTILS_BUILD_TARGET+="build_sphinx -a -E"
GRAPHICSMAGICK_RUN_DEPENDS= ${LOCALBASE}/bin/gm:graphics/GraphicsMagick
IMAGEMAGICK_RUN_DEPENDS= ${LOCALBASE}/bin/convert:graphics/ImageMagick6
-PILLOW_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
REDIS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}redis>0:databases/py-redis@${PY_FLAVOR}
WAND_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Wand>0:graphics/py-wand@${PY_FLAVOR}
@@ -44,10 +43,20 @@ PILLOW_DESC= Use internal image processing
REDIS_DESC= Use REDIS as Key Value Store
WAND_DESC= Use Wand with ImageMagick
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MPILLOW}
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+.endif
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/build/sphinx/html && \
${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} \
"! -name .buildinfo -and ! -name objects.inv")
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>