aboutsummaryrefslogtreecommitdiff
path: root/graphics/qt4-imageformats/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/qt4-imageformats/Makefile')
-rw-r--r--graphics/qt4-imageformats/Makefile29
1 files changed, 16 insertions, 13 deletions
diff --git a/graphics/qt4-imageformats/Makefile b/graphics/qt4-imageformats/Makefile
index 4fdfb4e9eaf1..9c21375da7ac 100644
--- a/graphics/qt4-imageformats/Makefile
+++ b/graphics/qt4-imageformats/Makefile
@@ -8,7 +8,6 @@
PORTNAME= imageformats
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 0
CATEGORIES?= graphics
PKGNAMEPREFIX= qt4-
@@ -34,23 +33,27 @@ MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
PATH=${WRKSRC}/bin:$$PATH
DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
- src/dbus src/network src/opengl src/phonon \
- src/qt3support src/script src/sql src/testlib \
- src/tools src/xmlpatterns src/3rdparty/clucene \
- src/3rdparty/kdebase src/3rdparty/kdelibs src/3rdparty/webkit
-EXTRACT_AFTER_ARGS= |${TAR} -xf -
+ src/activeqt src/dbus src/multimedia src/network src/opengl \
+ src/openvg src/phonon src/qt3support src/s60installs \
+ src/s60main src/script src/scripttools src/sql src/testlib \
+ src/tools src/winmain src/xml src/xmlpatterns \
+ src/3rdparty/clucene src/3rdparty/freetype \
+ src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
+ src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
+EXTRACT_AFTER_ARGS= | ${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
-WRKSRC= ${WRKDIR}/${DISTNAME}/src/plugins/${PORTNAME}
-CONFIGURE_WRKSRC=${WRKSRC}/../../..
+BUILD_WRKSRC= ${WRKSRC}/src/plugins/${PORTNAME}
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
pre-configure:
- ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
- ${MKDIR} ${WRKSRC}/../../../mkspecs
- ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../../bin/moc
- ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/../../../bin/rcc
+ ${MKDIR} ${WRKSRC}/mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/bin/rcc
.include <bsd.port.mk>