aboutsummaryrefslogtreecommitdiff
path: root/graphics/quat-gui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/quat-gui/Makefile')
-rw-r--r--graphics/quat-gui/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/graphics/quat-gui/Makefile b/graphics/quat-gui/Makefile
index 6fb643daca2e..54895a8862e7 100644
--- a/graphics/quat-gui/Makefile
+++ b/graphics/quat-gui/Makefile
@@ -18,8 +18,6 @@ LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk
OPTIONS_DEFINE= OPTIMIZED_CFLAGS DOCS
-UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
-
USE_XORG= xext
USE_GL= gl glut
GNU_CONFIGURE= yes
@@ -29,7 +27,7 @@ CONFIGURE_ARGS= --datadir=${PREFIX}/share/doc
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
+DOCSDIR= ${PREFIX}/share/doc/${PKGBASE}
PORTDOCS= *
PLIST_FILES= bin/quat
@@ -51,7 +49,7 @@ post-patch:
${WRKSRC}/gui/Makefile.in
@${REINPLACE_CMD} -e \
's|<FL/fl_file_chooser.H>|<FL/Fl_File_Chooser.H>| ; \
- s|/doc/quat/|/doc/${UNIQUENAME}/|' \
+ s|/doc/quat/|/doc/${PKGBASE}/|' \
${WRKSRC}/gui/MainWindow.cxx
# disable data file installation since distfile does not do
# The Right Thing(TM)
@@ -60,7 +58,7 @@ post-patch:
s|^(SUBDIRS.*)doc|\1|' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \
- 's|@PACKAGE@|${UNIQUENAME}|' \
+ 's|@PACKAGE@|${PKGBASE}|' \
${WRKSRC}/doc/Makefile.in
post-install: