aboutsummaryrefslogtreecommitdiff
path: root/graphics/sdl_gfx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/sdl_gfx/Makefile')
-rw-r--r--graphics/sdl_gfx/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/graphics/sdl_gfx/Makefile b/graphics/sdl_gfx/Makefile
index b19d4519583d..9081decbaa94 100644
--- a/graphics/sdl_gfx/Makefile
+++ b/graphics/sdl_gfx/Makefile
@@ -7,15 +7,14 @@
#
PORTNAME= sdl_gfx
-PORTVERSION= 2.0.13
-PORTREVISION= 3
+PORTVERSION= 2.0.16
CATEGORIES= graphics
MASTER_SITES= http://www.ferzkopp.net/Software/%SUBDIR%/ \
http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
MASTER_SITE_SUBDIR= SDL_gfx-${PORTVERSION:R}
DISTNAME= SDL_gfx-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= mva@sysfault.org
COMMENT= SDL graphics drawing primitives and other support functions
USE_AUTOTOOLS= libtool:15
@@ -23,16 +22,20 @@ USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --includedir=${PREFIX}/include \
- --disable-mmx
+CONFIGURE_ARGS= --includedir=${PREFIX}/include
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
USE_LDCONFIG= yes
+OPTIONS= MMX "Enable MMX instruction set (i386 only)" Off
+
.include <bsd.port.pre.mk>
.if defined(WITH_MMX) && (${ARCH} == "i386")
+CONFIGURE_ARGS+=--enable-mmx
CFLAGS+= -DUSE_MMX
+.else
+CONFIGURE_ARGS=--disable-mmx
.endif
.include <bsd.port.post.mk>