aboutsummaryrefslogtreecommitdiff
path: root/graphics/swftools/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/swftools/Makefile')
-rw-r--r--graphics/swftools/Makefile26
1 files changed, 17 insertions, 9 deletions
diff --git a/graphics/swftools/Makefile b/graphics/swftools/Makefile
index 74a7b6c9d344..ea15c75268e5 100644
--- a/graphics/swftools/Makefile
+++ b/graphics/swftools/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= swftools
-PORTVERSION= 0.8.1
-PORTREVISION= 1
+PORTVERSION= 0.9.0
CATEGORIES= graphics
MASTER_SITES= http://www.swftools.org/
@@ -18,21 +17,27 @@ COMMENT= SWF manipulation and generation utilities
LIB_DEPENDS= t1.5:${PORTSDIR}/devel/t1lib \
jpeg.9:${PORTSDIR}/graphics/jpeg \
ungif.5:${PORTSDIR}/graphics/libungif \
- freetype.9:${PORTSDIR}/print/freetype2
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
-USE_GNOME= gnometarget pkgconfig
+OPTIONS= LAME "LAME MP3 audio encoder support" off
+
+USE_GNOME= pkgconfig
+USE_GL= glut
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-MAN1= font2swf.1 gif2swf.1 jpeg2swf.1 pdf2swf.1 png2swf.1 \
- swfbbox.1 swfc.1 swfcombine.1 swfdump.1 swfextract.1 \
- swfstrings.1 wav2swf.1
+MAN1= as3compile.1 font2swf.1 gif2swf.1 jpeg2swf.1 pdf2swf.1 \
+ png2swf.1 swfbbox.1 swfc.1 swfcombine.1 swfdump.1 \
+ swfextract.1 swfrender.1 swfstrings.1 wav2swf.1
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-.if defined(WITH_LAME) || exists(${LOCALBASE}/lib/libmp3lame.a)
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_LAME)
LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
.else
CONFIGURE_ARGS+= --disable-lame
@@ -40,7 +45,10 @@ CONFIGURE_ARGS+= --disable-lame
post-patch:
@${REINPLACE_CMD} -e 's| -O | |g ; \
+ s|/usr/include/fontconfig|${LOCALBASE}/include/fontconfig|g ; \
s|/usr/local/include|${LOCALBASE}/include|g ; \
s|/usr/local/lib|${LOCALBASE}/lib|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/python/d ; \
+ /avi2swf/d' ${WRKSRC}/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>