aboutsummaryrefslogtreecommitdiff
path: root/graphics/ufraw/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ufraw/Makefile')
-rw-r--r--graphics/ufraw/Makefile64
1 files changed, 35 insertions, 29 deletions
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index 339973e30859..d4319c218a72 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -5,45 +5,51 @@
# $FreeBSD$
#
-PORTNAME= ufraw
-PORTVERSION= 0.9.1
-PORTREVISION= 2
-CATEGORIES= graphics gnome
-MASTER_SITES= SF
-
-MAINTAINER= infofarmer@FreeBSD.org
-COMMENT= Read and manipulate raw images from digital cameras
-
-BUILD_DEPENDS= gimp:${PORTSDIR}/graphics/gimp
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- tiff.4:${PORTSDIR}/graphics/tiff
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
-GNU_CONFIGURE= yes
-USE_XLIB= yes
-USE_GMAKE= yes
-USE_GNOME= glib20 gnomehack intltool intlhack gtk20 libartlgpl2
-WANT_GNOME= yes
-
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
- CFLAGS="${CFLAGS} -I ${LOCALBASE}/include"
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
+PORTNAME= ufraw
+PORTVERSION= 0.10
+CATEGORIES= graphics gnome
+MASTER_SITES= SF
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Read and manipulate raw images from digital cameras
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ png.5:${PORTSDIR}/graphics/png \
+ gimpui-2.0:${PORTSDIR}/graphics/gimp \
+ lcms.1:${PORTSDIR}/graphics/lcms
+
+GCONF_SCHEMAS= ${PORTNAME}.schemas
+GNU_CONFIGURE= yes
+USE_XLIB= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20 glib20 gnomehack intltool intlhack libartlgpl2 pkgconfig
+WANT_GNOME= yes
+
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS= -I${LOCALBASE}/include
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man --enable-mime
.ifndef WITHOUT_EXIF
-LIB_DEPENDS+= exif:${PORTSDIR}/graphics/libexif
-CONFIGURE_ARGS+= --with-libexif
+LIB_DEPENDS+= exif:${PORTSDIR}/graphics/libexif
+CONFIGURE_ARGS+=--with-libexif
.ifndef WITHOUT_EXIV2
-LIB_DEPENDS+= exiv2:${PORTSDIR}/graphics/exiv2
-CONFIGURE_ARGS+= --with-exiv2
+LIB_DEPENDS+= exiv2:${PORTSDIR}/graphics/exiv2
+CONFIGURE_ARGS+=--with-exiv2
.endif
.endif
-MAN1= ufraw.1
+MAN1= ufraw.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 504105
-BROKEN= Needs memmem(3)
+BROKEN= Needs memmem(3)
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/@schemasdir/s|datadir|sysconfdir|' ${WRKSRC}/Makefile.in
+
.include <bsd.port.post.mk>