aboutsummaryrefslogtreecommitdiff
path: root/graphics/vvv/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/vvv/Makefile')
-rw-r--r--graphics/vvv/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/graphics/vvv/Makefile b/graphics/vvv/Makefile
new file mode 100644
index 000000000000..9714de9fc298
--- /dev/null
+++ b/graphics/vvv/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: vvv
+# Date created: 10 Sep 2005
+# Whom: Igor Pokrovsky <ip@doom.homeunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vvv
+PORTVERSION= 1.0
+CATEGORIES= graphics
+MASTER_SITES= http://www.inf.ufes.br/~thomas/graphics/vvv/
+DISTNAME= ${PORTNAME}_unix
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ip@doom.homeunix.org
+COMMENT= A tutorial tool for understanding viewing and projection in OpenGL
+
+BUILD_DEPENDS= ${X11BASE}/lib/libglui.a:${PORTSDIR}/devel/glui
+LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut
+
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_GL= yes
+USE_X_PREFIX= yes
+MAKE_ENV= OS=unix X11BASE="${X11BASE}"
+ALL_TARGET= ${PORTNAME}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= vvv.html
+
+post-patch:
+ @${REINPLACE_CMD} -i '' -e 's|g\([c+]\)\1|${CXX}|g' \
+ ${WRKSRC}/Makefile
+ @${RM} ${WRKSRC}/glui.h # we are using glui from the port
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.ifndef (NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>