aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile4
-rw-r--r--graphics/hs-HGL/Makefile5
-rw-r--r--graphics/hs-HGL/distinfo1
-rw-r--r--graphics/hs-HGL/files/patch-Graphics__HGL__Internals__Utilities.hs11
-rw-r--r--graphics/hs-HGL/files/patch-HGL.cabal11
-rw-r--r--graphics/hs-HGL/pkg-plist44
-rw-r--r--graphics/hs-hgl/Makefile64
-rw-r--r--graphics/hs-hgl/distinfo3
-rw-r--r--graphics/hs-hgl/pkg-descr15
-rw-r--r--graphics/hs-hgl/pkg-message6
-rw-r--r--graphics/hs-hgl/pkg-plist38
11 files changed, 29 insertions, 173 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 59eac195fe21..260cd23f73d2 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -322,8 +322,10 @@
SUBDIR += gx
SUBDIR += hobbes-icons-xpm
SUBDIR += hppsmtools
+ SUBDIR += hs-cairo
SUBDIR += hs-HGL
- SUBDIR += hs-hgl
+ SUBDIR += hs-soegtk
+ SUBDIR += hs-svgcairo
SUBDIR += hsetroot
SUBDIR += hugin
SUBDIR += icoconvert
diff --git a/graphics/hs-HGL/Makefile b/graphics/hs-HGL/Makefile
index 85fd038aea77..228373530997 100644
--- a/graphics/hs-HGL/Makefile
+++ b/graphics/hs-HGL/Makefile
@@ -7,13 +7,16 @@
PORTNAME= HGL
PORTVERSION= 3.2.0.2
+PORTREVISION= 1
CATEGORIES= graphics haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= A simple Haskell graphics library based on X11 or Win32
+LICENSE= BSD
+
CABAL_SETUP= Setup.hs
-USE_HACKAGE= X11
+USE_CABAL= X11
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/graphics/hs-HGL/distinfo b/graphics/hs-HGL/distinfo
index 8cfcf5ab6d5b..a01b658da4ff 100644
--- a/graphics/hs-HGL/distinfo
+++ b/graphics/hs-HGL/distinfo
@@ -1,3 +1,2 @@
-MD5 (cabal/HGL-3.2.0.2.tar.gz) = fd653c4fe622312920754a5ec35f4d65
SHA256 (cabal/HGL-3.2.0.2.tar.gz) = 7f0734d1a8a8ad1fdfff44b7838a2d8e6aef025a08549461bc2946b78cdb8c8f
SIZE (cabal/HGL-3.2.0.2.tar.gz) = 38914
diff --git a/graphics/hs-HGL/files/patch-Graphics__HGL__Internals__Utilities.hs b/graphics/hs-HGL/files/patch-Graphics__HGL__Internals__Utilities.hs
new file mode 100644
index 000000000000..0b03fe9d5ceb
--- /dev/null
+++ b/graphics/hs-HGL/files/patch-Graphics__HGL__Internals__Utilities.hs
@@ -0,0 +1,11 @@
+--- ./Graphics/HGL/Internals/Utilities.hs.orig 2009-11-03 15:50:11.000000000 +0100
++++ ./Graphics/HGL/Internals/Utilities.hs 2011-03-13 18:31:25.754332789 +0100
+@@ -20,7 +20,7 @@
+ modMVar, modMVar_
+ ) where
+
+-import qualified Control.Exception as E (bracket, try, IOException, tryJust, ioErrors)
++import qualified Control.OldException as E (bracket, try, IOException, tryJust, ioErrors)
+ import Control.Concurrent( MVar, takeMVar, putMVar )
+
+ bracket :: IO a -> (a -> IO b) -> (a -> IO c) -> IO c
diff --git a/graphics/hs-HGL/files/patch-HGL.cabal b/graphics/hs-HGL/files/patch-HGL.cabal
new file mode 100644
index 000000000000..3733424e49f1
--- /dev/null
+++ b/graphics/hs-HGL/files/patch-HGL.cabal
@@ -0,0 +1,11 @@
+--- ./HGL.cabal.orig 2009-11-03 15:50:11.000000000 +0100
++++ ./HGL.cabal 2011-03-13 18:29:56.867337655 +0100
+@@ -22,7 +22,7 @@
+
+ library
+ if flag(split-base)
+- build-depends: base >= 3 && < 4, array
++ build-depends: base >= 3, array
+ else
+ build-depends: base < 2
+ exposed-modules:
diff --git a/graphics/hs-HGL/pkg-plist b/graphics/hs-HGL/pkg-plist
deleted file mode 100644
index cf79ba076332..000000000000
--- a/graphics/hs-HGL/pkg-plist
+++ /dev/null
@@ -1,44 +0,0 @@
-@comment $FreeBSD$
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Core.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Draw.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Draw/Brush.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Draw/Font.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Draw/Monad.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Draw/Pen.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Draw/Picture.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Draw/Region.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Draw/Text.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Internals/Draw.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Internals/Event.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Internals/Events.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Internals/Flag.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Internals/Types.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Internals/Utilities.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Key.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Run.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Units.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Utils.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Window.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/X11/DC.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/X11/Display.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/X11/Timer.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/X11/Types.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/X11/Window.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/SOE.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
-%%LIBDIR_REL%%/register.sh
-%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
-%%NOPORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/X11
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Internals
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL/Draw
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics/HGL
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Graphics
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
-@dirrm %%LIBDIR_REL%%
-@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
-@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
-@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
-@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
diff --git a/graphics/hs-hgl/Makefile b/graphics/hs-hgl/Makefile
deleted file mode 100644
index 722c5a2795af..000000000000
--- a/graphics/hs-hgl/Makefile
+++ /dev/null
@@ -1,64 +0,0 @@
-# New ports collection makefile for: hgl
-# Date created: 22 January 2002
-# Whom: octaphial
-#
-# $FreeBSD$
-#
-
-PORTNAME= hgl
-PORTVERSION= 2.0.4
-PORTREVISION= 4
-CATEGORIES= graphics haskell
-MASTER_SITES= http://haskell.org/graphics/downloads/
-PKGNAMEPREFIX= hs-
-DISTNAME= graphics-${PORTVERSION}.src
-
-MAINTAINER= octaphial@yahoo.com
-COMMENT= Graphics library for Hugs98, an implementation of Haskell 98
-
-RUN_DEPENDS= hugs:${PORTSDIR}/lang/hugs
-
-WRKSRC= ${WRKDIR}/graphics-${PORTVERSION}
-USE_GMAKE= yes
-USE_XORG= x11
-
-HGL_LIBS= ${PREFIX}/lib/hugs/x11
-HGL_DOCS= ${PREFIX}/share/doc/hs-hgl
-
-BUILD_WRKSRC= ${WRKSRC}/lib/x11
-MAKE_ARGS= system=FreeBSD \
- hugs_install=${HGL_LIBS} \
- X_dir=${LOCALBASE} \
- CC=${CC}
-ALL_TARGET= all
-
-do-build:
- @cd ${BUILD_WRKSRC}; ${GMAKE} ${MAKE_ARGS}
-
-do-install:
- ${MKDIR} ${HGL_LIBS}
- ${MKDIR} ${HGL_LIBS}/demos
- ${INSTALL_DATA} ${WRKSRC}/lib/x11/*.hs ${HGL_LIBS}
- ${INSTALL_PROGRAM} ${WRKSRC}/lib/x11/*.o ${HGL_LIBS}
- ${INSTALL_PROGRAM} ${WRKSRC}/lib/x11/*.so ${HGL_LIBS}
- ${INSTALL_DATA} ${WRKSRC}/demos/* ${HGL_LIBS}/demos
- ${INSTALL_DATA} ${WRKSRC}/test/* ${HGL_LIBS}/demos
-
-post-install:
- ${MKDIR} ${HGL_DOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${HGL_DOCS}
- ${INSTALL_DATA} ${WRKSRC}/License ${HGL_DOCS}
- ${INSTALL_DATA} ${WRKSRC}/Readme ${HGL_DOCS}
- ${INSTALL_DATA} ${WRKSRC}/Version ${HGL_DOCS}
- ${INSTALL_DATA} ${WRKSRC}/Version-2.0.4 ${HGL_DOCS}
- @${ECHO} ''
- @${CAT} ${PKGMESSAGE}
- @${ECHO} ''
-
-.include <bsd.port.pre.mk>
-
-.if ${MACHINE_ARCH:L} == "amd64"
-MAKE_ARGS+= CFLAGS=-fPIC
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/graphics/hs-hgl/distinfo b/graphics/hs-hgl/distinfo
deleted file mode 100644
index ae3f2d79e6ae..000000000000
--- a/graphics/hs-hgl/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (graphics-2.0.4.src.tar.gz) = 60da7bc8f3a2414778fe1e693ba54ab4
-SHA256 (graphics-2.0.4.src.tar.gz) = bb1ad2e51eecdc4a72e7f252b6b42796afe6b7482f9867c4f49d54f821d2fcf2
-SIZE (graphics-2.0.4.src.tar.gz) = 170252
diff --git a/graphics/hs-hgl/pkg-descr b/graphics/hs-hgl/pkg-descr
deleted file mode 100644
index 6116627eafb5..000000000000
--- a/graphics/hs-hgl/pkg-descr
+++ /dev/null
@@ -1,15 +0,0 @@
-From homepage of HGL:
-
-The HGL gives the programmer access to the most interesting parts of
-the Win32 and X11 library without exposing the programmer to the pain
-and anguish usually associated with using these interfaces. The library
-library is distributed as open source and is suitable for use in
-teaching and in applications.
-
-...
-
-WWW: http://haskell.org/graphics/
-
-
- - Byunghyun Oh
- octaphial@yahoo.com
diff --git a/graphics/hs-hgl/pkg-message b/graphics/hs-hgl/pkg-message
deleted file mode 100644
index b85c2079371a..000000000000
--- a/graphics/hs-hgl/pkg-message
+++ /dev/null
@@ -1,6 +0,0 @@
-----------
-Please set the environment variable HUGSFLAGS "-P{Hugs}/x11:".
-
-In tcsh: setenv HUGSFLAGS "-P{Hugs}/x11:"
-In sh: export HUGSFLAGS="-P{Hugs}/x11:"
-----------
diff --git a/graphics/hs-hgl/pkg-plist b/graphics/hs-hgl/pkg-plist
deleted file mode 100644
index e5975b7ec81c..000000000000
--- a/graphics/hs-hgl/pkg-plist
+++ /dev/null
@@ -1,38 +0,0 @@
-share/doc/hs-hgl/License
-share/doc/hs-hgl/Readme
-share/doc/hs-hgl/Version
-share/doc/hs-hgl/Version-2.0.4
-share/doc/hs-hgl/Graphics.dvi
-share/doc/hs-hgl/Graphics.tex
-share/doc/hs-hgl/appendix.tex
-share/doc/hs-hgl/graphics.bib
-share/doc/hs-hgl/oldappendix.tex
-lib/hugs/x11/demos/HelloWorld.hs
-lib/hugs/x11/demos/GTest.hs
-lib/hugs/x11/demos/Tests.hs
-lib/hugs/x11/GraphicsCore.hs
-lib/hugs/x11/GraphicsDC.hs
-lib/hugs/x11/GraphicsEvent.hs
-lib/hugs/x11/GraphicsEvents.hs
-lib/hugs/x11/GraphicsFlag.hs
-lib/hugs/x11/GraphicsFont.hs
-lib/hugs/x11/GraphicsKey.hs
-lib/hugs/x11/GraphicsPicture.hs
-lib/hugs/x11/GraphicsRegion.hs
-lib/hugs/x11/GraphicsTimer.hs
-lib/hugs/x11/GraphicsUtils.hs
-lib/hugs/x11/GraphicsWindow.hs
-lib/hugs/x11/GraphicsWindows.hs
-lib/hugs/x11/Graphics_Utilities.hs
-lib/hugs/x11/SOEGraphics.hs
-lib/hugs/x11/X.hs
-lib/hugs/x11/X.o
-lib/hugs/x11/X.so
-lib/hugs/x11/Xlib.hs
-lib/hugs/x11/Xlib.o
-lib/hugs/x11/Xlib.so
-lib/hugs/x11/Xlib_StdDIS.hs
-lib/hugs/x11/Xlib_StdDIS.so
-@dirrm share/doc/hs-hgl
-@dirrm lib/hugs/x11/demos
-@dirrm lib/hugs/x11