aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/4va/Makefile3
-rw-r--r--graphics/blender-doc/Makefile12
-rw-r--r--graphics/seejpeg/Makefile3
-rw-r--r--graphics/xfig/Makefile3
4 files changed, 9 insertions, 12 deletions
diff --git a/graphics/4va/Makefile b/graphics/4va/Makefile
index 53a5608ad704..8d5dd10a8018 100644
--- a/graphics/4va/Makefile
+++ b/graphics/4va/Makefile
@@ -19,9 +19,6 @@ MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
4VA_DATA_FILES= 16cell.4vd 24cell.4vd 5cell.4vd 600cell.4vd ctor.4vd \
ctor2.4vd hcube.4vd hsph.4vd sin.4vd tripris.4vd
-post-extract:
- @${CHMOD} -R go-x ${WRKSRC}/
-
do-install:
.for file in 4va 4vdmake ctorus cutctorus
${INSTALL_PROGRAM} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/bin
diff --git a/graphics/blender-doc/Makefile b/graphics/blender-doc/Makefile
index b4d15fe83f14..238be4d60a0c 100644
--- a/graphics/blender-doc/Makefile
+++ b/graphics/blender-doc/Makefile
@@ -17,9 +17,15 @@ NO_ARCH= yes
SUB_FILES= pkg-message
+.include <bsd.port.pre.mk>
+
post-extract:
- @${CHMOD} u+rwx ${WRKSRC}/* && ${CHMOD} u+rwx ${WRKSRC}/*/* && \
- ${CHMOD} u+rwx ${WRKSRC}/*/*/* && ${CHMOD} u+rwx ${WRKSRC}/*/*/*/*
+.if ${OSVERSION} < 1100077
+# chmod -R bug.
+# Do not use "-exec ... +", because of the same bug, it will not work.
+ @${FIND} ${WRKSRC} -type d -exec ${CHMOD} 755 {} \;
+.endif
+
@cd ${WRKSRC}/htmlI/PartAT/volumetrics/gfx/ && \
${RM} -r "Nuova cartella" "Nuova cartella (2)"
@@ -27,4 +33,4 @@ do-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@cd ${WRKSRC}/&&${COPYTREE_SHARE} "htmlI htmlII" ${STAGEDIR}${DOCSDIR}/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/seejpeg/Makefile b/graphics/seejpeg/Makefile
index 0634dfb2e75a..116f92889127 100644
--- a/graphics/seejpeg/Makefile
+++ b/graphics/seejpeg/Makefile
@@ -19,7 +19,4 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/seejpeg man/man1/seejpeg.1.gz
-post-extract:
- ${CHMOD} 0644 ${WRKSRC}/Makefile
-
.include <bsd.port.mk>
diff --git a/graphics/xfig/Makefile b/graphics/xfig/Makefile
index 62c35bbd6167..f88b91ef39f2 100644
--- a/graphics/xfig/Makefile
+++ b/graphics/xfig/Makefile
@@ -56,10 +56,7 @@ post-extract:
@${RM} ${WRKSRC}/Doc/html/images/pspbrwse.jbf
@${RM} ${WRKSRC}/Libraries/Examples/xfig.exe.stackdump
@${RM} ${WRKSRC}/Libraries/Fasteners/Fasteners.tar
- @cd ${WRKSRC}/Doc && ${FIND} -s . -type d -print0 | ${XARGS} -0 ${CHMOD} a+rx
@cd ${WRKSRC}/Doc && ${FIND} . -type f -print0 | ${XARGS} -0 ${CHMOD} a-x+r
- @${CHMOD} a+rx ${WRKSRC}/Libraries
- @cd ${WRKSRC}/Libraries && ${FIND} -s . -type d -print0 | ${XARGS} -0 ${CHMOD} a+rx
@cd ${WRKSRC}/Libraries && ${FIND} . -type f -print0 | ${XARGS} -0 ${CHMOD} a-x+r
@${CP} ${WRKSRC}/Doc/xfig.man ${WRKSRC}