aboutsummaryrefslogtreecommitdiff
path: root/irc/darkbot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/darkbot/Makefile')
-rw-r--r--irc/darkbot/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/irc/darkbot/Makefile b/irc/darkbot/Makefile
new file mode 100644
index 000000000000..575804943f9c
--- /dev/null
+++ b/irc/darkbot/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: Darkbot
+# Date created: 24 February 2003
+# Whom: A. Gabriel <backslash@BSDCode.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= darkbot
+PORTVERSION= 6f6_r6
+CATEGORIES= irc
+MASTER_SITES= http://darkbot.sourceforge.net/archive/unix/ \
+ http://www.BSDCode.org/port/
+
+MAINTAINER= backslash@BSDCode.org
+COMMENT= IRC talking bot with a very fast algorithm for its database
+
+PLIST= ${WRKDIR}/plist
+
+MAN1= darkbot.1
+MANCOMPRESSED= yes
+
+GNU_CONFIGURE= yes
+IS_INTERACTIVE= yes
+
+pre-install:
+ ${CAT} ${MASTERDIR}/pkg-plist | ${SED} -e "s,/usr/local,${LOCALBASE},g" > ${PLIST}
+
+.include <bsd.port.mk>