aboutsummaryrefslogtreecommitdiff
path: root/irc/sircd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/sircd/Makefile')
-rw-r--r--irc/sircd/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/irc/sircd/Makefile b/irc/sircd/Makefile
index 2418dbe7ac62..cf59e82854ec 100644
--- a/irc/sircd/Makefile
+++ b/irc/sircd/Makefile
@@ -7,32 +7,29 @@
#
PORTNAME= sircd
-PORTVERSION= 0.2.5a
+PORTVERSION= 0.4.0
CATEGORIES= irc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.sircd.org/files/
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/a/-alpha/}
MAINTAINER= ports@FreeBSD.org
USE_OPENSSL= yes
-WRKSRC= ${WRKDIR}/${DISTNAME}/server
USE_GMAKE= yes
+MAKE_ENV= LD="${CC}" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
ALL_TARGET= release
INSTALLS_SHLIB= yes
-post-patch:
- @${PERL} -pi -e "s,-lssl,-lssl -lcrypto,g" ${WRKSRC}/sircd/Makefile
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/sircd/sircd ${PREFIX}/sbin
- ${INSTALL} ${WRKSRC}/../syscore/libsyscore.so ${PREFIX}/lib
+ ${INSTALL_PROGRAM} ${WRKSRC}/sircd/sircd ${PREFIX}/sbin/sircd
${INSTALL_DATA} ${WRKSRC}/sircd/sircd.conf ${PREFIX}/etc/sircd.conf.sample
- ${MKDIR} ${PREFIX}/share/sircd/plugins
-.for file in mod_base.so mod_oper.so
- ${INSTALL} ${WRKSRC}/plugins/${file} ${PREFIX}/share/sircd/plugins
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/sircd/motd.txt ${PREFIX}/share/sircd
+ ${INSTALL_DATA} ${WRKSRC}/syscore/libsyscore.so ${PREFIX}/lib/libsyscore.so
+ @${MKDIR} ${PREFIX}/lib/sircd
+ ${INSTALL_DATA} ${WRKSRC}/sircd/motd.txt ${PREFIX}/lib/sircd/motd.txt
+ @${MKDIR} ${PREFIX}/lib/sircd/plugins
+ ${INSTALL_DATA} ${WRKSRC}/plugins/*.so ${PREFIX}/lib/sircd/plugins
.include <bsd.port.mk>