aboutsummaryrefslogtreecommitdiff
path: root/java/cacao/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/cacao/Makefile')
-rw-r--r--java/cacao/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/java/cacao/Makefile b/java/cacao/Makefile
new file mode 100644
index 000000000000..be3393493623
--- /dev/null
+++ b/java/cacao/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: cacao
+# Date created: 2005-04-28
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= cacao
+PORTVERSION= 0.97
+CATEGORIES= java devel
+MASTER_SITES= http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PORTVERSION}/
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= JIT compiler for JAVA
+
+BUILD_DEPENDS= ${LOCALBASE}/share/classpath/glibj.zip:${PORTSDIR}/java/classpath
+
+USE_AUTOTOOLS= libltdl
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-classpath-prefix=${LOCALBASE}
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == amd64
+IGNORE= unsupported architecture
+.endif
+
+.include <bsd.port.post.mk>