aboutsummaryrefslogtreecommitdiff
path: root/java/openjfx14
diff options
context:
space:
mode:
Diffstat (limited to 'java/openjfx14')
-rw-r--r--java/openjfx14/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/java/openjfx14/Makefile b/java/openjfx14/Makefile
index 7b8c05991ef6..5680f1862979 100644
--- a/java/openjfx14/Makefile
+++ b/java/openjfx14/Makefile
@@ -95,6 +95,9 @@ _INSTALLDIR= ${PREFIX}/${PKGBASE}
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
+# Suppress errors with lld >= 17 due to undefined symbols.
+LDFLAGS+= -Wl,--undefined-version
+
post-extract:
${MKDIR} ${WRKDIR}/jars
.for f in core grouping queries queryparser sandbox