aboutsummaryrefslogtreecommitdiff
path: root/lang/caml-light/files/patch-src_launch_Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/caml-light/files/patch-src_launch_Makefile')
-rw-r--r--lang/caml-light/files/patch-src_launch_Makefile24
1 files changed, 15 insertions, 9 deletions
diff --git a/lang/caml-light/files/patch-src_launch_Makefile b/lang/caml-light/files/patch-src_launch_Makefile
index 38b39aaca442..afba4c517322 100644
--- a/lang/caml-light/files/patch-src_launch_Makefile
+++ b/lang/caml-light/files/patch-src_launch_Makefile
@@ -1,13 +1,19 @@
---- src/launch/Makefile.orig Wed Feb 22 15:03:26 1995
-+++ src/launch/Makefile Sun Aug 6 11:58:56 2006
-@@ -17,16 +17,17 @@
- chmod a+x /tmp/testscr
- sh -c 'if sh -c /tmp/testscr 2>/dev/null; \
- then echo "#!$(BINDIR)/camlrun" > $(LIBDIR)/header; \
+--- src/launch/Makefile.orig 1995-02-22 10:33:26.000000000 +0100
++++ src/launch/Makefile 2011-11-12 10:26:48.000000000 +0100
+@@ -11,22 +11,15 @@
+ # have write permission in the current directory if NFS-mounted...
+
+ install:
+- (echo "#!$(BINDIR)/camlrun"; \
+- echo "exit 2"; \
+- cat testprog) > /tmp/testscr
+- chmod a+x /tmp/testscr
+- sh -c 'if sh -c /tmp/testscr 2>/dev/null; \
+- then echo "#!$(BINDIR)/camlrun" > $(LIBDIR)/header; \
- else cp camlexec $(LIBDIR)/header; \
-+ else ${BSD_INSTALL_SCRIPT} camlexec $(LIBDIR)/header; \
- fi'
- rm -f /tmp/testscr
+- fi'
+- rm -f /tmp/testscr
++ echo "#!$(BINDIR)/camlrun" > $(LIBDIR)/header
for script in camlc camllight camlmktop; do \
- cp $$script $(BINDIR)/$$script; \
+ ${BSD_INSTALL_SCRIPT} $$script $(BINDIR)/$$script; \