aboutsummaryrefslogtreecommitdiff
path: root/lang/clisp
diff options
context:
space:
mode:
Diffstat (limited to 'lang/clisp')
-rw-r--r--lang/clisp/Makefile64
-rw-r--r--lang/clisp/distinfo4
-rw-r--r--lang/clisp/files/patch-aa18
-rw-r--r--lang/clisp/files/patch-clisp-link.in20
-rw-r--r--lang/clisp/files/patch-makemake.in11
-rw-r--r--lang/clisp/pkg-descr7
-rw-r--r--lang/clisp/pkg-plist78
7 files changed, 58 insertions, 144 deletions
diff --git a/lang/clisp/Makefile b/lang/clisp/Makefile
index 5d4d64b6ca08..66eba8a42871 100644
--- a/lang/clisp/Makefile
+++ b/lang/clisp/Makefile
@@ -6,68 +6,30 @@
#
PORTNAME= clisp
-PORTVERSION= 2.30
-PORTREVISION= 2
-CATEGORIES= lang
-MASTER_SITES= ftp://cvs2.cons.org/pub/lisp/clisp/source/${PORTVERSION}/ \
- ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+PORTVERSION= 2.33.2
+CATEGORIES= lang lisp
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR=${PORTNAME}/release/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jakub@rehor.net
COMMENT= An ANSI Common Lisp
USE_BZIP2= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
-USE_GCC= 2.95
USE_GETTEXT= yes
-# -ino: 20050214-1307 taken from lang/perl5.8:
-LOCALE_CLEANUP= LANG="" LC_ALL="" LC_COLLATE="" LC_CTYPE="" \
- LC_MESSAGES="" LC_MONETARY="" LC_NUMERIC="" \
- LC_TIME=""
-CONFIGURE_ENV+= ${LOCALE_CLEANUP}
-MAKE_ENV+= ${LOCALE_CLEANUP}
-
-# In clisp-2.28, the build dies in the "regexp" module: the build target
-# invokes a configure script, which encounters a different CC variable than
-# the one the top-level configure cached. We'll explicitly set CC to avoid
-# this.
-MAKE_ENV+= CC="${CC}"
-CONFIGURE_ENV+= CC="${CC}"
-
-# The build uses INSTALL_* to copy files around, but since the Ports
-# INSTALL_* try to set file permissions, using them breaks non-root builds.
-# Instead, we'll just fix up permissions in the post-install target, after we
-# install the files.
-CONFIGURE_ENV+= INSTALL=${CP} INSTALL_DATA=${CP} INSTALL_PROGRAM=${CP} \
- INSTALL_SCRIPT=${CP} INSTALL_MAN=${CP}
-
# Build subdirectory
BUILD_DIRNAME=${CONFIGURE_TARGET}
-# These came from clisp-2.28's "configure" on my 4.4-R system,
-# with "--with-module=regexp --with-export-syscalls" added in.
+# Check ./configure --help in the distribution to see all modules
MAKEMAKE_ARGS=--prefix=${PREFIX} --with-readline --with-gettext \
--with-dynamic-ffi --with-module=regexp --with-export-syscalls
-# The post-install target uses these to fix permissions.
-DATA_PATHS=${PREFIX}/lib/clisp ${PREFIX}/share/doc/clisp \
- ${PREFIX}/share/locale/de/LC_MESSAGES/clisp.mo \
- ${PREFIX}/share/locale/de/LC_MESSAGES/clisplow.mo \
- ${PREFIX}/share/locale/en/LC_MESSAGES/clisp.mo \
- ${PREFIX}/share/locale/en/LC_MESSAGES/clisplow.mo \
- ${PREFIX}/share/locale/es/LC_MESSAGES/clisp.mo \
- ${PREFIX}/share/locale/es/LC_MESSAGES/clisplow.mo \
- ${PREFIX}/share/locale/fr/LC_MESSAGES/clisp.mo \
- ${PREFIX}/share/locale/fr/LC_MESSAGES/clisplow.mo \
- ${PREFIX}/share/locale/nl/LC_MESSAGES/clisp.mo \
- ${PREFIX}/share/locale/nl/LC_MESSAGES/clisplow.mo
-PROG_PATHS=${PREFIX}/bin/clisp
-MAN_PATHS=${PREFIX}/man/man1/clisp.1
-
.include <bsd.port.pre.mk>
+# If you have an Alpha machine, you may want to test this port and let
+# me know if you succeed.
.if ${ARCH} == "alpha"
BROKEN= "Does not compile on alpha"
.endif
@@ -75,7 +37,7 @@ BROKEN= "Does not compile on alpha"
# The source doesn't include a top-level Makefile, so we'll fake one.
post-extract:
@cd ${WRKSRC} && \
- printf "all install:\n\t@cd ${WRKSRC}/${BUILD_DIRNAME} && \$${MAKE} \$${MAKEFLAGS} \$$@\n" > ${WRKSRC}/Makefile
+ ${PRINTF} "all install:\n\t@cd ${WRKSRC}/${BUILD_DIRNAME} && \$${MAKE} \$${MAKEFLAGS} \$$@\n" > ${WRKSRC}/Makefile
# The 'configure' script stops short of doing this for us.
post-configure:
@@ -83,14 +45,6 @@ post-configure:
./makemake ${MAKEMAKE_ARGS} > Makefile && \
make config.lisp
-post-install:
- ${CHOWN} -R ${BINOWN}:${BINGRP} ${PROG_PATHS}
- ${CHMOD} -R ugo+rX,ugo-w ${PROG_PATHS}
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATA_PATHS}
- ${CHMOD} -R ugo+rX,ugo-w ${DATA_PATHS}
- ${CHOWN} -R ${MANOWN}:${MANGRP} ${MAN_PATHS}
- ${CHMOD} -R ugo+rX,ugo-w ${MAN_PATHS}
-
MAN1= clisp.1
.include <bsd.port.post.mk>
diff --git a/lang/clisp/distinfo b/lang/clisp/distinfo
index cde1df0599ec..94fe20e70e06 100644
--- a/lang/clisp/distinfo
+++ b/lang/clisp/distinfo
@@ -1,2 +1,2 @@
-MD5 (clisp-2.30.tar.bz2) = 29e80e430c6098c78dbd2e56334aaa90
-SIZE (clisp-2.30.tar.bz2) = 5652698
+MD5 (clisp-2.33.2.tar.bz2) = ee4ea316db1e843dcb16094bf500012f
+SIZE (clisp-2.33.2.tar.bz2) = 6091273
diff --git a/lang/clisp/files/patch-aa b/lang/clisp/files/patch-aa
deleted file mode 100644
index 36cbda81535a..000000000000
--- a/lang/clisp/files/patch-aa
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/makemake.in.orig Sun Jan 5 22:37:32 2003
-+++ src/makemake.in Sun Jan 5 22:39:09 2003
-@@ -1658,7 +1658,15 @@
- echol "htmldir = \$(prefix)${NEXT_}share${NEXT_}html"
- echol "dvidir = \$(prefix)${NEXT_}share${NEXT_}dvi"
- echol "docdir = \$(prefix)${NEXT_}share${NEXT_}doc"
-+fsstnd=freebsd
- case "$fsstnd" in
-+ freebsd)
-+ echol "mandir = \$(exec_prefix)${NEXT_}man"
-+ echol "docdir = \$(exec_prefix)${NEXT_}share${NEXT_}doc"
-+ echol "lispdocdir = \$(docdir)${NEXT_}clisp"
-+ echol "htmldir = \$(lispdocdir)"
-+ echol "dvidir = \$(lispdocdir)"
-+ ;;
- suse)
- echol "lispdocdir = \$(docdir)${NEXT_}packages${NEXT_}clisp"
- ;;
diff --git a/lang/clisp/files/patch-clisp-link.in b/lang/clisp/files/patch-clisp-link.in
deleted file mode 100644
index a71a7248a461..000000000000
--- a/lang/clisp/files/patch-clisp-link.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/clisp-link.in.orig Sun Jan 5 18:38:36 2003
-+++ src/clisp-link.in Sun Jan 5 18:39:24 2003
-@@ -282,7 +282,7 @@
- verbose "$destinationdir"/${LISPRUN} -B "$installbasedir" -M "$lispinitdir"/lispinit.mem -norc -q -i $to_load -x "(saveinitmem \"$destinationdir/lispinit.mem\")"
- # Generate new makevars
- LIBS=`echo $LIBS | sed s/','/'\\,'/g`
-- sed -e "s,^LIBS=.*\$,LIBS='${LIBS}'," -e "s,^FILES=.*\$,FILES='${FILES}'," < "$sourcedir"/makevars > "$destinationdir"/makevars
-+ sed -e "s;^LIBS=.*\$;LIBS='${LIBS}';" -e "s;^FILES=.*\$;FILES='${FILES}';" < "$sourcedir"/makevars > "$destinationdir"/makevars
- # Done.
- trap '' 1 2 15
- ;;
-@@ -421,7 +421,7 @@
- fi
- # Generate new makevars
- LIBS=`echo $LIBS | sed s/','/'\\,'/g`
-- sed -e "s,^LIBS=.*\$,LIBS='${LIBS}'," -e "s,^FILES=.*\$,FILES='${FILES}'," < "$sourcedir"/makevars > "$destinationdir"/makevars
-+ sed -e "s;^LIBS=.*\$;LIBS='${LIBS}';" -e "s;^FILES=.*\$;FILES='${FILES}';" < "$sourcedir"/makevars > "$destinationdir"/makevars
- fi
- # Done.
- trap '' 1 2 15
diff --git a/lang/clisp/files/patch-makemake.in b/lang/clisp/files/patch-makemake.in
new file mode 100644
index 000000000000..ac2db5c42f00
--- /dev/null
+++ b/lang/clisp/files/patch-makemake.in
@@ -0,0 +1,11 @@
+--- src/makemake.in.orig Thu May 27 10:43:39 2004
++++ src/makemake.in Tue Feb 15 21:23:34 2005
+@@ -1550,7 +1550,7 @@
+ echol "exec_prefix = ${EXEC_PREFIX}"
+ echol "bindir = \$(exec_prefix)${NEXT_}bin"
+ echol "shared = \$(prefix)${NEXT_}share"
+-echol "mandir = \$(shared)${NEXT_}man"
++echol "mandir = \$(prefix)${NEXT_}man"
+ echol "docdir = \$(shared)${NEXT_}doc"
+ case "$fsstnd" in
+ suse)
diff --git a/lang/clisp/pkg-descr b/lang/clisp/pkg-descr
index 57bc249a287a..03fd2a160b9e 100644
--- a/lang/clisp/pkg-descr
+++ b/lang/clisp/pkg-descr
@@ -15,6 +15,9 @@ GPL. You may distribute commercial applications compiled with CLISP,
see file COPYRIGHT in the CLISP distribution.
The user interface comes in German, English, French and Spanish, and
-can be change at run time.
+can be changed at run time.
-WWW: http://clisp.cons.org/
+WWW: http://clisp.sourceforge.net/
+
+- Jakub Rehor
+jakub@rehor.net
diff --git a/lang/clisp/pkg-plist b/lang/clisp/pkg-plist
index f611e2921446..b07e5057dd0f 100644
--- a/lang/clisp/pkg-plist
+++ b/lang/clisp/pkg-plist
@@ -10,67 +10,51 @@ lib/clisp/base/makevars
lib/clisp/base/modules.h
lib/clisp/base/modules.o
lib/clisp/clisp-link
-lib/clisp/data/UnicodeData.txt
+lib/clisp/data/UnicodeDataFull.txt
lib/clisp/data/clhs.txt
lib/clisp/full/libavcall.a
lib/clisp/full/libcallback.a
-lib/clisp/full/libnoreadline.a
lib/clisp/full/libcharset.a
+lib/clisp/full/libnoreadline.a
lib/clisp/full/lisp.a
lib/clisp/full/lisp.run
lib/clisp/full/lispinit.mem
lib/clisp/full/makevars
lib/clisp/full/modules.h
lib/clisp/full/modules.o
-lib/clisp/full/regex.o
lib/clisp/full/regexi.o
lib/clisp/full/regexp.dvi
-lib/clisp/full/regexp.o
lib/clisp/linkkit/clisp.h
+lib/clisp/linkkit/exporting.lisp
+lib/clisp/linkkit/modprep.lisp
lib/clisp/linkkit/modules.c
lib/clisp/linkkit/modules.d
-share/doc/clisp/ANNOUNCE
-share/doc/clisp/COPYRIGHT
-share/doc/clisp/GNU-GPL
-share/doc/clisp/MAGIC.add
-share/doc/clisp/NEWS
-share/doc/clisp/README
-share/doc/clisp/README.de
-share/doc/clisp/README.es
-share/doc/clisp/SUMMARY
-share/doc/clisp/CLOS-guide.txt
-share/doc/clisp/LISP-tutorial.txt
-share/doc/clisp/clisp.1
-share/doc/clisp/clisp.dvi
-share/doc/clisp/clisp.html
-share/doc/clisp/clisp.png
-share/doc/clisp/editors.txt
-share/doc/clisp/impnotes.css
-share/doc/clisp/impnotes.html
-share/locale/de/LC_MESSAGES/clisp.mo
-share/locale/de/LC_MESSAGES/clisplow.mo
-share/locale/en/LC_MESSAGES/clisp.mo
-share/locale/en/LC_MESSAGES/clisplow.mo
-share/locale/es/LC_MESSAGES/clisp.mo
-share/locale/es/LC_MESSAGES/clisplow.mo
-share/locale/fr/LC_MESSAGES/clisp.mo
-share/locale/fr/LC_MESSAGES/clisplow.mo
-share/locale/nl/LC_MESSAGES/clisp.mo
-share/locale/nl/LC_MESSAGES/clisplow.mo
-share/locale/ru/LC_MESSAGES/clisp.mo
-share/locale/ru/LC_MESSAGES/clisplow.mo
-@dirrm share/doc/clisp
-@dirrm lib/clisp/base
-@dirrm lib/clisp/data
-@dirrm lib/clisp/full
+%%PORTDOCS%%%%DOCSDIR%%/ANNOUNCE
+%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%PORTDOCS%%%%DOCSDIR%%/GNU-GPL
+%%PORTDOCS%%%%DOCSDIR%%/MAGIC.add
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.de
+%%PORTDOCS%%%%DOCSDIR%%/README.es
+%%PORTDOCS%%%%DOCSDIR%%/SUMMARY
+%%PORTDOCS%%%%DOCSDIR%%/clisp.dvi
+%%PORTDOCS%%%%DOCSDIR%%/clisp.html
+%%PORTDOCS%%%%DOCSDIR%%/clisp.ps
+%%PORTDOCS%%%%DOCSDIR%%/doc/CLOS-guide.txt
+%%PORTDOCS%%%%DOCSDIR%%/doc/LISP-tutorial.txt
+%%PORTDOCS%%%%DOCSDIR%%/doc/clisp.1
+%%PORTDOCS%%%%DOCSDIR%%/doc/clisp.dvi
+%%PORTDOCS%%%%DOCSDIR%%/doc/clisp.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/clisp.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/clisp.ps
+%%PORTDOCS%%%%DOCSDIR%%/doc/editors.txt
+%%PORTDOCS%%%%DOCSDIR%%/doc/impnotes.css
+%%PORTDOCS%%%%DOCSDIR%%/doc/impnotes.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/doc
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/clisp/linkkit
+@dirrm lib/clisp/full
+@dirrm lib/clisp/data
+@dirrm lib/clisp/base
@dirrm lib/clisp
-@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/de 2>/dev/null || true
-@unexec rmdir %D/share/locale/es/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/es 2>/dev/null || true
-@unexec rmdir %D/share/locale/fr/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/fr 2>/dev/null || true
-@unexec rmdir %D/share/locale/nl/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/nl 2>/dev/null || true
-@unexec rmdir %D/share/locale 2>/dev/null || true