aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang14/files
diff options
context:
space:
mode:
Diffstat (limited to 'lang/erlang14/files')
-rw-r--r--lang/erlang14/files/patch-aa26
-rw-r--r--lang/erlang14/files/patch-ab12
-rw-r--r--lang/erlang14/files/patch-ac27
-rw-r--r--lang/erlang14/files/patch-ad21
-rw-r--r--lang/erlang14/files/patch-ae18
-rw-r--r--lang/erlang14/files/patch-af19
-rw-r--r--lang/erlang14/files/patch-ag33
-rw-r--r--lang/erlang14/files/patch-ah84
-rw-r--r--lang/erlang14/files/patch-ai12
-rw-r--r--lang/erlang14/files/patch-aj18
-rw-r--r--lang/erlang14/files/patch-ak11
11 files changed, 255 insertions, 26 deletions
diff --git a/lang/erlang14/files/patch-aa b/lang/erlang14/files/patch-aa
deleted file mode 100644
index cd1261f30743..000000000000
--- a/lang/erlang14/files/patch-aa
+++ /dev/null
@@ -1,26 +0,0 @@
-*** erts/etc/unix/Install.src.ORIG Tue Nov 23 16:05:11 1999
---- erts/etc/unix/Install.src Thu Dec 30 16:39:15 1999
-***************
-*** 165,174 ****
- # Fixing the man pages
- #
-
-! if [ -d $ERL_ROOT/man ]
-! then
-! cd $ERL_ROOT
-! ./misc/format_man_pages $ERL_ROOT
-! fi
-!
-
---- 165,175 ----
- # Fixing the man pages
- #
-
-! # This is not needed!
-! # if [ -d $ERL_ROOT/man ]
-! # then
-! # cd $ERL_ROOT
-! # ./misc/format_man_pages $ERL_ROOT
-! # fi
-
-+ exit 0
diff --git a/lang/erlang14/files/patch-ab b/lang/erlang14/files/patch-ab
new file mode 100644
index 000000000000..69155f380ed1
--- /dev/null
+++ b/lang/erlang14/files/patch-ab
@@ -0,0 +1,12 @@
+--- lib/inets/priv/Makefile.orig Tue Nov 28 20:38:31 2000
++++ lib/inets/priv/Makefile Tue Nov 28 20:38:38 2000
+@@ -57,7 +57,7 @@
+
+ release_spec: opt
+ $(INSTALL_DIR) $(RELSYSDIR)/priv/bin
+- $(INSTALL_PROGRAM) $(EXECUTABLES) $(RELSYSDIR)/priv/bin
++ $(INSTALL_SCRIPT) $(EXECUTABLES) $(RELSYSDIR)/priv/bin
+
+ release_docs_spec:
+
+# End
diff --git a/lang/erlang14/files/patch-ac b/lang/erlang14/files/patch-ac
new file mode 100644
index 000000000000..b574011d6429
--- /dev/null
+++ b/lang/erlang14/files/patch-ac
@@ -0,0 +1,27 @@
+--- erts/etc/common/Makefile.in.orig Tue Nov 28 20:41:14 2000
++++ erts/etc/common/Makefile.in Tue Nov 28 20:46:05 2000
+@@ -65,6 +65,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_DIR = $(INSTALL) -d
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
++INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_DATA = @INSTALL_DATA@
+
+ ifeq ($(findstring solaris,$(TARGET)),solaris)
+@@ -238,13 +239,13 @@
+ endif
+ $(INSTALL_DIR) $(RELEASE_PATH)/erts-$(VSN)/bin
+ ifneq ($(findstring vxworks,$(TARGET)), vxworks)
+- $(INSTALL_PROGRAM) erl.src $(RELEASE_PATH)/erts-$(VSN)/bin
++ $(INSTALL_SCRIPT) erl.src $(RELEASE_PATH)/erts-$(VSN)/bin
+ endif
+ $(INSTALL_PROGRAM) $(INSTALL_PROGS) $(RELEASE_PATH)/erts-$(VSN)/bin
+- $(INSTALL_PROGRAM) $(INSTALL_TOP) $(RELEASE_PATH)
++ $(INSTALL_SCRIPT) $(INSTALL_TOP) $(RELEASE_PATH)
+ ifneq ($(INSTALL_MISC),)
+ $(INSTALL_DIR) $(RELEASE_PATH)/misc
+- $(INSTALL_PROGRAM) $(INSTALL_MISC) $(RELEASE_PATH)/misc
++ $(INSTALL_SCRIPT) $(INSTALL_MISC) $(RELEASE_PATH)/misc
+ endif
+ ifneq ($(INSTALL_SRC),)
+ $(INSTALL_DIR) $(RELEASE_PATH)/erts-$(VSN)/src
diff --git a/lang/erlang14/files/patch-ad b/lang/erlang14/files/patch-ad
new file mode 100644
index 000000000000..cb87f5b64db0
--- /dev/null
+++ b/lang/erlang14/files/patch-ad
@@ -0,0 +1,21 @@
+--- lib/os_mon/src/disksup.erl.orig Sat Dec 2 22:19:26 2000
++++ lib/os_mon/src/disksup.erl Sat Dec 2 22:19:34 2000
+@@ -81,6 +81,9 @@
+ check_disk_space(State) when State#state.os == {unix, solaris} ->
+ Result = os:cmd("/usr/bin/df -lk"),
+ check_disks_solaris(skip_to_eol(Result), State#state.threshold);
++check_disk_space(State) when State#state.os == {unix, freebsd} ->
++ Result = os:cmd("/bin/df -k -t ufs"),
++ check_disks_solaris(skip_to_eol(Result), State#state.threshold);
+ check_disk_space(State) when State#state.os == {unix, sunos4} ->
+ Result = os:cmd("df"),
+ check_disks_solaris(skip_to_eol(Result), State#state.threshold).
+@@ -162,6 +165,8 @@
+ {4,_,_} -> {unix, sunos4};
+ V -> exit({{unknown_os_version, V}, {disk_sup, get_os, []}})
+ end;
++ {unix, freebsd} ->
++ {unix, freebsd};
+ {win32,W} ->
+ {win32,W};
+ Type ->
diff --git a/lang/erlang14/files/patch-ae b/lang/erlang14/files/patch-ae
new file mode 100644
index 000000000000..f4d48694e46f
--- /dev/null
+++ b/lang/erlang14/files/patch-ae
@@ -0,0 +1,18 @@
+--- erts/autoconf/configure.in.orig Sat Dec 2 22:27:49 2000
++++ erts/autoconf/configure.in Sat Dec 2 22:34:30 2000
+@@ -638,10 +638,13 @@
+ # Os mon stuff.
+ #--------------------------------------------------------------------
+ AC_SUBST(os_mon_programs)
+-AC_CHECK_LIB(kstat, kstat_open, [os_mon_programs="$os_mon_programs cpu_sup"])
++AC_SUBST(os_mon_kstat)
++AC_CHECK_LIB(kstat, kstat_open, [os_mon_kstat="-lkstat", os_mon_programs="$os_mon_programs cpu_sup"])
+ case $host_os in
+ solaris2*)
+ os_mon_programs="$os_mon_programs ferrule mod_syslog" ;;
++ freebsd*)
++ os_mon_programs="$os_mon_programs cpu_sup ferrule mod_syslog" ;;
+ esac
+
+
+# End
diff --git a/lang/erlang14/files/patch-af b/lang/erlang14/files/patch-af
new file mode 100644
index 000000000000..4e20d048f0aa
--- /dev/null
+++ b/lang/erlang14/files/patch-af
@@ -0,0 +1,19 @@
+--- lib/os_mon/c_src/Makefile.in.orig Tue Nov 23 16:14:47 1999
++++ lib/os_mon/c_src/Makefile.in Sat Dec 2 22:35:09 2000
+@@ -53,6 +53,7 @@
+ PROGRAMS = \
+ memsup @os_mon_programs@
+ C_FILES= $(PROGRAMS:%=%.c)
++LKSTAT= @os_mon_kstat@
+ endif
+
+ TARGET_FILES= $(PROGRAMS:%=$(BINDIR)/%)
+@@ -97,7 +98,7 @@
+ $(LD) $(LDFLAGS) -o $@ $<
+
+ $(BINDIR)/cpu_sup: $(OBJDIR)/cpu_sup.o
+- $(LD) $(LDFLAGS) -o $@ $< -lkstat
++ $(LD) $(LDFLAGS) -o $@ $< $(LKSTAT)
+
+ $(OBJDIR)/%.o: %.c
+ $(CC) -c -o $@ $(ALL_CFLAGS) $<
diff --git a/lang/erlang14/files/patch-ag b/lang/erlang14/files/patch-ag
new file mode 100644
index 000000000000..b32003f79b65
--- /dev/null
+++ b/lang/erlang14/files/patch-ag
@@ -0,0 +1,33 @@
+--- lib/os_mon/c_src/memsup.c.orig Mon Sep 20 23:05:24 1999
++++ lib/os_mon/c_src/memsup.c Sat Dec 2 22:23:25 2000
+@@ -89,6 +89,12 @@
+ #include <ioLib.h>
+ #include <memLib.h>
+ #endif
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#include <sys/sysctl.h>
++#include <sys/vmmeter.h>
++#include <vm/vm_param.h>
++#endif
+
+ /* commands */
+ #include "memsup.h"
+@@ -172,6 +178,16 @@
+ load_statistics();
+ *tot = (latest.numBytesFree + latest.numBytesAlloc) >> shiftleft;
+ *used = latest.numBytesAlloc >> shiftleft;
++#elif defined(__FreeBSD__)
++ int mib[2];
++ size_t len;
++ struct vmtotal memory;
++ mib[0] = CTL_VM;
++ mib[1] = VM_METER;
++ len = sizeof memory;
++ sysctl(mib, 2, &memory, &len, NULL, 0);
++ *tot = memory.t_vm >> shiftleft;
++ *used = memory.t_avm >> shiftleft;
+ #elif defined(_SC_AVPHYS_PAGES) /* Does this exist on others than Solaris2? */
+ unsigned long avPhys, phys, pgSz;
+
+# End
diff --git a/lang/erlang14/files/patch-ah b/lang/erlang14/files/patch-ah
new file mode 100644
index 000000000000..7da039d6bdf1
--- /dev/null
+++ b/lang/erlang14/files/patch-ah
@@ -0,0 +1,84 @@
+--- lib/os_mon/c_src/cpu_sup.c.orig Sat Dec 2 22:12:38 2000
++++ lib/os_mon/c_src/cpu_sup.c Sat Dec 2 22:47:11 2000
+@@ -26,7 +26,14 @@
+ */
+
+ #include<stdio.h>
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#include <sys/sysctl.h>
++#include <sys/param.h>
++#include <sys/user.h>
++#else
+ #include<kstat.h>
++#endif
+
+ #define FD_IN 0
+ #define FD_OUT 1
+@@ -45,20 +52,23 @@
+ static void send(unsigned int data);
+ static void error(char* err_msg);
+
++#ifndef __FreeBSD__
+ static kstat_ctl_t *kc;
+ static kstat_t *ks;
++#endif
+
+ int main(int argc, char** argv) {
+- kid_t kid;
+ char cmd;
+ int rc;
++#ifndef __FreeBSD__
++ kid_t kid;
+
+ kc = kstat_open();
+ if(!kc) error("Can't open header kstat");
+
+ ks = kstat_lookup(kc,"unix",0,"system_misc");
+ if(!ks) error("Can't open system_misc kstat");
+-
++#endif
+
+ while(1) {
+ rc = read(FD_IN, &cmd, sizeof(cmd));
+@@ -79,6 +89,32 @@
+ }
+
+ static unsigned int measure(char* name) {
++#ifdef __FreeBSD__
++ size_t len;
++ int mib[3];
++ if (!strcmp (name, "nproc")) {
++ mib[0] = CTL_KERN;
++ mib[1] = KERN_PROC;
++ mib[2] = KERN_PROC_ALL;
++ sysctl(mib, 3, NULL, &len, NULL, 0);
++ return len/sizeof(struct kinfo_proc);
++ } else {
++ struct loadavg load;
++ mib[0] = CTL_VM;
++ mib[1] = VM_LOADAVG;
++ len = sizeof load;
++ sysctl(mib, 2, &load, &len, NULL, 0);
++ if (!strcmp (name, "avenrun_1min")) {
++ return load.ldavg[0] * 256 / load.fscale;
++ } else if (!strcmp (name, "avenrun_5min")) {
++ return load.ldavg[1] * 256 / load.fscale;
++ } else if (!strcmp (name, "avenrun_15min")) {
++ return load.ldavg[2] * 256 / load.fscale;
++ } else {
++ return -1;
++ }
++ }
++#else
+ kstat_named_t* entry;
+
+ kstat_read(kc,ks,NULL);
+@@ -90,6 +126,7 @@
+ return -1;
+
+ return entry->value.ul;
++#endif
+ }
+
+ static void send(unsigned int data) {
diff --git a/lang/erlang14/files/patch-ai b/lang/erlang14/files/patch-ai
new file mode 100644
index 000000000000..6be7b984151f
--- /dev/null
+++ b/lang/erlang14/files/patch-ai
@@ -0,0 +1,12 @@
+--- lib/os_mon/c_src/ferrule.c.orig Sat Dec 2 22:13:49 2000
++++ lib/os_mon/c_src/ferrule.c Sat Dec 2 22:14:03 2000
+@@ -17,7 +17,9 @@
+ */
+ #include <stdio.h>
+ #include <string.h>
++#ifndef __FreeBSD__
+ #include <stropts.h>
++#endif
+ #include <poll.h>
+ #include <unistd.h>
+ #include <sys/types.h>
diff --git a/lang/erlang14/files/patch-aj b/lang/erlang14/files/patch-aj
new file mode 100644
index 000000000000..2efd40c6460c
--- /dev/null
+++ b/lang/erlang14/files/patch-aj
@@ -0,0 +1,18 @@
+--- ./erts/etc/unix/Install.src.orig Wed Jan 17 17:18:57 2001
++++ ./erts/etc/unix/Install.src Wed Jan 17 17:35:40 2001
+@@ -97,7 +97,8 @@
+ chmod 755 start_erl
+ fi
+
+-if [ -d $ERL_ROOT/lib/sasl* ]
++set $ERL_ROOT/lib/sasl*
++if [ -d $1 ]
+ then
+ (cd $ERL_ROOT/releases
+ echo %I_VSN% %I_SYSTEM_VSN% > start_erl.data)
+@@ -171,4 +172,4 @@
+ ./misc/format_man_pages $ERL_ROOT
+ fi
+
+-
++exit 0
diff --git a/lang/erlang14/files/patch-ak b/lang/erlang14/files/patch-ak
new file mode 100644
index 000000000000..446cd1c7323a
--- /dev/null
+++ b/lang/erlang14/files/patch-ak
@@ -0,0 +1,11 @@
+--- lib/inets/examples/Makefile.orig Tue Nov 28 20:35:48 2000
++++ lib/inets/examples/Makefile Tue Nov 28 20:36:24 2000
+@@ -176,7 +176,7 @@
+ $(INSTALL_DIR) $(RELSYSDIR)/examples/server_root/auth
+ $(INSTALL_DATA) $(AUTH_FILES) $(RELSYSDIR)/examples/server_root/auth
+ $(INSTALL_DIR) $(RELSYSDIR)/examples/server_root/cgi-bin
+- $(INSTALL_PROGRAM) $(CGI_FILES) $(RELSYSDIR)/examples/server_root/cgi-bin
++ $(INSTALL_SCRIPT) $(CGI_FILES) $(RELSYSDIR)/examples/server_root/cgi-bin
+ $(INSTALL_DIR) $(RELSYSDIR)/examples/server_root/conf
+ $(INSTALL_DATA) $(CONF_FILES) $(RELSYSDIR)/examples/server_root/conf
+ $(INSTALL_DIR) $(RELSYSDIR)/examples/server_root/htdocs/open