aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang
diff options
context:
space:
mode:
Diffstat (limited to 'lang/erlang')
-rw-r--r--lang/erlang/Makefile10
-rw-r--r--lang/erlang/Makefile.lib66
-rw-r--r--lang/erlang/Makefile.man16
-rw-r--r--lang/erlang/distinfo18
-rw-r--r--lang/erlang/files/patch-Makefile.in21
-rw-r--r--lang/erlang/files/patch-erts_configure13
-rw-r--r--lang/erlang/files/patch-erts_emulator_hipe_hipe__x86.c14
-rw-r--r--lang/erlang/files/patch-lib_dialyzer_src_Makefile38
-rw-r--r--lang/erlang/files/patch-lib_dialyzer_src_dialyzer.hrl.src14
-rw-r--r--lang/erlang/files/patch-lib_hipe_cerl_cerl__hipeify.erl34
-rw-r--r--lang/erlang/pkg-message2
-rw-r--r--lang/erlang/pkg-plist4
12 files changed, 140 insertions, 110 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 7ada577b0eef..f2b3d6f76062 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= erlang
-PORTVERSION= r10b10
+PORTVERSION= r11b0
PORTEPOCH= 1
CATEGORIES= lang parallel
MASTER_SITES= http://www.erlang.org/download/ \
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.erlang.org/download/ \
http://www.erlang.org/download/ \
http://erlang.stacken.kth.se/download/ \
http://www.csd.uu.se/ftp/mirror/erlang/download/
-DISTNAME= otp_src_R10B-10
+DISTNAME= otp_src_R11B-0
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${ERLANG_MAN} ${ERLANG_DOCS}
DIST_SUBDIR= erlang
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -60,9 +60,9 @@ LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
.endif
.endif
-ERLANG_MAN= otp_doc_man_R10B-10.tar.gz
+ERLANG_MAN= otp_doc_man_R11B-0.tar.gz
.if !defined(NOPORTDOCS)
-ERLANG_DOCS= otp_doc_html_R10B-10.tar.gz
+ERLANG_DOCS= otp_doc_html_R11B-0.tar.gz
.endif
ERLANG_PLIST= ${WRKDIR}/pkg-plist
@@ -134,6 +134,8 @@ post-install:
.endif
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/lib/erlang
@${CHMOD} -R o+rX-w,g+rX-w ${PREFIX}/lib/erlang
+ @${INSTALL_DATA} ${WRKSRC}/lib/dialyzer/doc/*.txt \
+ ${LOCALBASE}/lib/erlang/lib/dialyzer-*/doc/
# All non-library files.
diff --git a/lang/erlang/Makefile.lib b/lang/erlang/Makefile.lib
index ed747a4e6e07..9c27cb9d7dac 100644
--- a/lang/erlang/Makefile.lib
+++ b/lang/erlang/Makefile.lib
@@ -1,47 +1,49 @@
# $FreeBSD$
-ERTS_VSN= 5.4.13
-OTP_LIBS= appmon-2.1.5 \
- asn1-1.4.4.9 \
- compiler-4.3.12 \
+ERTS_VSN= 5.5
+OTP_LIBS= appmon-2.1.6 \
+ asn1-1.4.4.10 \
+ compiler-4.4 \
cosEvent-2.1 \
cosEventDomain-1.1 \
cosFileTransfer-1.1.2 \
- cosNotification-1.1.2 \
+ cosNotification-1.1.3 \
cosProperty-1.1.1 \
cosTime-1.1 \
cosTransactions-1.2 \
- crypto-1.4 \
- debugger-3.0.1 \
- edoc-0.6.8 \
+ crypto-1.5 \
+ debugger-3.1 \
+ dialyzer-1.4.1 \
+ edoc-0.6.9 \
erl_interface-3.5.5 \
et-1.0 \
- gs-1.5.4 \
+ gs-1.5.5 \
hipe-3.5.5 \
- ic-4.2.9 \
- inets-4.7.2 \
+ ic-4.2.11 \
+ inets-4.7.4 \
+ inviso-0.1 \
jinterface-1.3 \
- kernel-2.10.13 \
- megaco-3.3 \
- mnemosyne-1.2.5.1 \
- mnesia-4.2.5 \
- mnesia_session-1.1.5 \
- observer-0.9.6.2 \
+ kernel-2.11 \
+ megaco-3.3.5 \
+ mnemosyne-1.2.6 \
+ mnesia-4.3.1 \
+ mnesia_session-1.1.6 \
+ observer-0.9.7 \
odbc-2.0.6 \
- orber-3.6.2 \
- os_mon-2.0 \
+ orber-3.6.3 \
+ os_mon-2.1 \
otp_mibs-1.0.4 \
- parsetools-1.3.2 \
+ parsetools-1.4 \
pman-2.5.2 \
- runtime_tools-1.5.1.1 \
- sasl-2.1.1 \
- snmp-4.7.1 \
- ssh-0.9.1 \
- ssl-3.0.11 \
- stdlib-1.13.12 \
- syntax_tools-1.4.3 \
- toolbar-1.2.1 \
- tools-2.4.7 \
- tv-2.1.2 \
- webtool-0.8.2 \
- xmerl-1.0.3
+ runtime_tools-1.6 \
+ sasl-2.1.2 \
+ snmp-4.7.4 \
+ ssh-0.9.2 \
+ ssl-3.0.12 \
+ stdlib-1.14 \
+ syntax_tools-1.5.0 \
+ toolbar-1.3 \
+ tools-2.5 \
+ tv-2.1.3 \
+ webtool-0.8.3 \
+ xmerl-1.0.5
diff --git a/lang/erlang/Makefile.man b/lang/erlang/Makefile.man
index 106ea3e09e7c..df2c5f512f67 100644
--- a/lang/erlang/Makefile.man
+++ b/lang/erlang/Makefile.man
@@ -108,6 +108,7 @@ MAN3= CosEventChannelAdmin.3 \
dbg.3 \
debugger.3 \
dets.3 \
+ dialyzer.3 \
dict.3 \
digraph.3 \
digraph_utils.3 \
@@ -181,6 +182,11 @@ MAN3= CosEventChannelAdmin.3 \
instrument.3 \
int.3 \
interceptors.3 \
+ inviso.3 \
+ inviso_as_lib.3 \
+ inviso_lfm.3 \
+ inviso_lfm_tpfreader.3 \
+ inviso_rt.3 \
io.3 \
io_lib.3 \
lib.3 \
@@ -290,6 +296,7 @@ MAN3= CosEventChannelAdmin.3 \
sys.3 \
systools.3 \
tags.3 \
+ tftp.3 \
timer.3 \
toolbar.3 \
ttb.3 \
@@ -298,8 +305,14 @@ MAN3= CosEventChannelAdmin.3 \
webtool.3 \
win32reg.3 \
wrap_log_reader.3 \
+ xmerl.3 \
+ xmerl_eventp.3 \
+ xmerl_scan.3 \
+ xmerl_xpath.3 \
+ xmerl_xs.3 \
xref.3 \
yecc.3 \
+ zip.3 \
zlib.3
MAN4= app.4 \
@@ -315,4 +328,5 @@ MAN6= crypto.6 \
runtime_tools.6 \
sasl.6 \
snmp.6 \
- ssl.6
+ ssl.6 \
+ stdlib.6
diff --git a/lang/erlang/distinfo b/lang/erlang/distinfo
index 8b95abe63e05..d45464cf1e2d 100644
--- a/lang/erlang/distinfo
+++ b/lang/erlang/distinfo
@@ -1,9 +1,9 @@
-MD5 (erlang/otp_src_R10B-10.tar.gz) = c1405c885f07d661b7362b822d571586
-SHA256 (erlang/otp_src_R10B-10.tar.gz) = bd87e1b09f1f3d694fc32ef4d27372e25c95ce35b383c7747ab40c27471c28ac
-SIZE (erlang/otp_src_R10B-10.tar.gz) = 9445437
-MD5 (erlang/otp_doc_man_R10B-10.tar.gz) = 207e00bcaf5a9428bd86e3973f9b699f
-SHA256 (erlang/otp_doc_man_R10B-10.tar.gz) = 8ecfc9b627200f59c35591a743e03a587258ddcdd39052a0b2cb58b80f6fc20b
-SIZE (erlang/otp_doc_man_R10B-10.tar.gz) = 594690
-MD5 (erlang/otp_doc_html_R10B-10.tar.gz) = d6e9655ff07af642025b0465c5e7e1a6
-SHA256 (erlang/otp_doc_html_R10B-10.tar.gz) = 2373d6935b44b64a137bf8ba198dca3fb782d0c072735b172ae4420c380a5d9c
-SIZE (erlang/otp_doc_html_R10B-10.tar.gz) = 4655081
+MD5 (erlang/otp_src_R11B-0.tar.gz) = 367d9d3ba979cd278b78d6d0393982ba
+SHA256 (erlang/otp_src_R11B-0.tar.gz) = 1806ea681b72be216e5365b29479dcb5253f0d828c021282711f5eae984c9f11
+SIZE (erlang/otp_src_R11B-0.tar.gz) = 10844070
+MD5 (erlang/otp_doc_man_R11B-0.tar.gz) = 172591538db42e81b814a77f30da4fa4
+SHA256 (erlang/otp_doc_man_R11B-0.tar.gz) = 09b93f43b6bb048d3b66296e94bb6379dbac11217e2ffbe074c2492fe777ee39
+SIZE (erlang/otp_doc_man_R11B-0.tar.gz) = 624684
+MD5 (erlang/otp_doc_html_R11B-0.tar.gz) = 8d163f4d16c98ba2e979688842a55a9f
+SHA256 (erlang/otp_doc_html_R11B-0.tar.gz) = 68cb74d5979dd2ea75c03e892e7ce1446eff27af37d9bdd4fd9778a433a19f68
+SIZE (erlang/otp_doc_html_R11B-0.tar.gz) = 4662110
diff --git a/lang/erlang/files/patch-Makefile.in b/lang/erlang/files/patch-Makefile.in
deleted file mode 100644
index 86bb7e10acf2..000000000000
--- a/lang/erlang/files/patch-Makefile.in
+++ /dev/null
@@ -1,21 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.in.orig Tue Sep 14 13:46:54 2004
-+++ Makefile.in Thu Oct 7 14:36:38 2004
-@@ -528,14 +528,9 @@
- # Erlang base public files
- #
- install.bin:
-- rm -f $(BINDIR)/erl $(BINDIR)/erlc \
-- $(BINDIR)/ecc $(BINDIR)/elink $(BINDIR)/ear $(BINDIR)/escript
-+ rm -f $(BINDIR)/erl $(BINDIR)/erlc
- ${LN_S} $(ERLANG_BINDIR)/erl $(BINDIR)/erl
- ${LN_S} $(ERLANG_BINDIR)/erlc $(BINDIR)/erlc
-- ${LN_S} $(ERLANG_BINDIR)/ecc $(BINDIR)/ecc
-- ${LN_S} $(ERLANG_BINDIR)/elink $(BINDIR)/elink
-- ${LN_S} $(ERLANG_BINDIR)/ear $(BINDIR)/ear
-- ${LN_S} $(ERLANG_BINDIR)/escript $(BINDIR)/escript
-
- #
- # Directories needed before we can install
diff --git a/lang/erlang/files/patch-erts_configure b/lang/erlang/files/patch-erts_configure
index 1b67a5a50324..6d776f45c1e0 100644
--- a/lang/erlang/files/patch-erts_configure
+++ b/lang/erlang/files/patch-erts_configure
@@ -1,9 +1,6 @@
-
-$FreeBSD$
-
---- erts/configure.orig
-+++ erts/configure
-@@ -1283,6 +1283,7 @@
+--- erts/configure.orig Tue May 16 19:39:04 2006
++++ erts/configure Thu May 18 15:40:47 2006
+@@ -1319,6 +1319,7 @@
i586) ARCH=x86;;
i686) ARCH=x86;;
x86_64) ARCH=amd64;;
@@ -11,10 +8,10 @@ $FreeBSD$
ppc) ARCH=ppc;;
ppc64) ARCH=ppc64;;
"Power Macintosh") ARCH=ppc;;
-@@ -5804,7 +5805,9 @@
+@@ -6799,7 +6800,9 @@
echo $ac_n "checking for unreliable floating point execptions""... $ac_c" 1>&6
- echo "configure:5807: checking for unreliable floating point execptions" >&5
+ echo "configure:6802: checking for unreliable floating point execptions" >&5
-if test "$cross_compiling" = yes; then
+if test "${ARCH}" = amd64; then
+ erl_ok=reliable
diff --git a/lang/erlang/files/patch-erts_emulator_hipe_hipe__x86.c b/lang/erlang/files/patch-erts_emulator_hipe_hipe__x86.c
new file mode 100644
index 000000000000..b7086a076357
--- /dev/null
+++ b/lang/erlang/files/patch-erts_emulator_hipe_hipe__x86.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- erts/emulator/hipe/hipe_x86.c.orig
++++ erts/emulator/hipe/hipe_x86.c
+@@ -106,7 +106,7 @@
+ abort();
+ map_start = mmap(map_hint, map_bytes,
+ PROT_EXEC|PROT_READ|PROT_WRITE,
+- MAP_PRIVATE|MAP_ANONYMOUS
++ MAP_PRIVATE|MAP_ANON
+ #ifdef __x86_64__
+ |MAP_32BIT
+ #endif
diff --git a/lang/erlang/files/patch-lib_dialyzer_src_Makefile b/lang/erlang/files/patch-lib_dialyzer_src_Makefile
new file mode 100644
index 000000000000..521909e142a2
--- /dev/null
+++ b/lang/erlang/files/patch-lib_dialyzer_src_Makefile
@@ -0,0 +1,38 @@
+
+$FreeBSD$
+
+--- lib/dialyzer/src/Makefile.orig
++++ lib/dialyzer/src/Makefile
+@@ -65,7 +65,7 @@
+ dialyzer_plt \
+ dialyzer_typesig
+
+-EXTRA_FILES= dialyzer.hrl ../plt/dialyzer_init_plt ## automatically generated
++EXTRA_FILES= dialyzer.hrl ## automatically generated
+
+ ERL_FILES= $(MODULES:%=%.erl)
+ INSTALL_FILES= $(MODULES:%=$(EBIN)/%.$(EMULATOR)) $(APP_TARGET) $(APPUP_TARGET)
+@@ -89,7 +89,7 @@
+ # Targets
+ # ----------------------------------------------------
+
+-debug opt: $(TARGET_FILES) $(DIALYZER_DIR)/plt/dialyzer_init_plt
++debug opt: $(TARGET_FILES)
+
+ docs:
+
+@@ -125,7 +125,6 @@
+ dialyzer.hrl: dialyzer.hrl.src ../vsn.mk Makefile
+ sed -e "s;%VSN%;$(VSN);" \
+ -e "s;%DEF_LIBS%;\[$(DIALYZER_DEF_LIBS)\];" \
+- -e "s;%DIALYZER_DIR%;\"$(DIALYZER_DIR)\";" \
+ $< > $@
+
+ # ---------------------------------------------------------------------
+@@ -155,6 +154,5 @@
+ $(INSTALL_DIR) $(RELSYSDIR)/ebin
+ $(INSTALL_DATA) $(INSTALL_FILES) $(RELSYSDIR)/ebin
+ $(INSTALL_DIR) $(RELSYSDIR)/plt
+- $(INSTALL_DATA) ../plt/dialyzer_init_plt $(RELSYSDIR)/plt
+
+ release_docs_spec:
diff --git a/lang/erlang/files/patch-lib_dialyzer_src_dialyzer.hrl.src b/lang/erlang/files/patch-lib_dialyzer_src_dialyzer.hrl.src
new file mode 100644
index 000000000000..698769adb62a
--- /dev/null
+++ b/lang/erlang/files/patch-lib_dialyzer_src_dialyzer.hrl.src
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- lib/dialyzer/src/dialyzer.hrl.src.orig
++++ lib/dialyzer/src/dialyzer.hrl.src
+@@ -22,7 +22,7 @@
+
+ %% Values will be set by the Makefile
+ -define(DEFAULT_LIBS, %DEF_LIBS%).
+--define(DIALYZER_DIR, %DIALYZER_DIR%).
++-define(DIALYZER_DIR, code:lib_dir (dialyzer)).
+
+ -record(analysis, {analysis_pid, core_transform=cerl_typean,
+ defines=[], doc_plt,
diff --git a/lang/erlang/files/patch-lib_hipe_cerl_cerl__hipeify.erl b/lang/erlang/files/patch-lib_hipe_cerl_cerl__hipeify.erl
deleted file mode 100644
index 3f19ff5bfe1d..000000000000
--- a/lang/erlang/files/patch-lib_hipe_cerl_cerl__hipeify.erl
+++ /dev/null
@@ -1,34 +0,0 @@
-
-$FreeBSD$
-
---- lib/hipe/cerl/cerl_hipeify.erl.orig
-+++ lib/hipe/cerl/cerl_hipeify.erl
-@@ -14,7 +14,7 @@
- %% Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
- %% USA
- %%
--%% $Id$
-+%% $Id: cerl_hipeify.erl,v 1.23 2006/03/10 13:40:37 tobiasl Exp $
- %%
- %% @author Richard Carlsson <richardc@csd.uu.se>
- %% @copyright 2000-2004 Richard Carlsson
-@@ -361,6 +361,19 @@
- cerl:atom_val(F),
- length(As))
- of
-+ {yes, ?PRIMOP_IS_RECORD} ->
-+ %% Needs additional testing
-+ [_, Tag, Arity] = As,
-+ case (cerl:is_c_atom(Tag) andalso
-+ cerl:is_c_int(Arity)) of
-+ true ->
-+ %% The primop might need further handling
-+ N1 = cerl:c_atom(?PRIMOP_IS_RECORD),
-+ E1 = cerl:update_c_primop(E, N1, As),
-+ rewrite_primop(E1, N1, As, S);
-+ false ->
-+ cerl:update_c_call(E, M, F, As)
-+ end;
- {yes, N} ->
- %% The primop might need further handling
- N1 = cerl:c_atom(N),
diff --git a/lang/erlang/pkg-message b/lang/erlang/pkg-message
index 1f830b0ed3e2..80a942a14e49 100644
--- a/lang/erlang/pkg-message
+++ b/lang/erlang/pkg-message
@@ -7,7 +7,7 @@ Installation tips:
You can find an emacs mode for Erlang here:
- ${LOCALBASE}/lib/erlang/lib/tools-2.4.7/emacs
+ ${LOCALBASE}/lib/erlang/lib/tools-2.5/emacs
You may wish to add the following line to /etc/manpath.config:
diff --git a/lang/erlang/pkg-plist b/lang/erlang/pkg-plist
index 4b348a9b8d82..1dd0772416d7 100644
--- a/lang/erlang/pkg-plist
+++ b/lang/erlang/pkg-plist
@@ -1,6 +1,10 @@
+bin/dialyzer
+bin/epmd
bin/erl
bin/erl_call
bin/erlc
+bin/run_erl
+bin/to_erl
@comment Insert PLIST here
@comment -=[ begin PLIST.lib-erlang ]=-
@comment -=[ end PLIST.lib-erlang ]=-