aboutsummaryrefslogtreecommitdiff
path: root/lang/icc
diff options
context:
space:
mode:
Diffstat (limited to 'lang/icc')
-rw-r--r--lang/icc/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index df123e737017..9e5c0dc8c93c 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -181,8 +181,7 @@ post-patch:
>${WRKSRC}/opt/${COMPILERDIR}/include/stdbool.h
.endif
-.if ( ${OSVERSION} >= 470101 && ${OSVERSION} < 500000 ) || \
- ( ${OSVERSION} >= 500042 )
+.if ( ${OSVERSION} >= 500042 )
OBJCOPY_OPS= --redefine-sym stdin=__stdinp \
--redefine-sym stdout=__stdoutp \
--redefine-sym stderr=__stderrp
@@ -200,8 +199,7 @@ do-build:
.if ( ${OSVERSION} < 502101 )
@cd ${WRKSRC} && ${CC} ${CFLAGS} -c ${FILESDIR}/cxa_atexit.c
.endif
-.if ( ${OSVERSION} < 470101 ) || \
- ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500042 )
+.if ( ${OSVERSION} < 500042 )
@${CC} ${CFLAGS} -c -o ${WRKSRC}/stdin.o ${FILESDIR}/stdin.c
@${CC} ${CFLAGS} -c -o ${WRKSRC}/stdout.o ${FILESDIR}/stdout.c
@${CC} ${CFLAGS} -c -o ${WRKSRC}/stderr.o ${FILESDIR}/stderr.c