aboutsummaryrefslogtreecommitdiff
path: root/lang/petite-chez/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/petite-chez/Makefile')
-rw-r--r--lang/petite-chez/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/lang/petite-chez/Makefile b/lang/petite-chez/Makefile
index 87a7914067aa..6ccf2914b89a 100644
--- a/lang/petite-chez/Makefile
+++ b/lang/petite-chez/Makefile
@@ -33,6 +33,7 @@ CONFIGURE_ARGS= --installprefix=${PREFIX} \
--force-relink \
--nogzip-man-pages \
-m=${CHEZ_MACHTYPE}
+MAKE_JOBS_UNSAFE= yes
ALL_TARGET= build
@@ -74,7 +75,10 @@ post-configure:
${WRKSRC}/Mf-${CHEZ_MACHTYPE}
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/petite
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/scheme-script
+.for bin in petite scheme-script
+ ${CHMOD} u+w ${STAGEDIR}${PREFIX}/bin/${bin}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${bin}
+ ${CHMOD} u-w ${STAGEDIR}${PREFIX}/bin/${bin}
+.endfor
.include <bsd.port.post.mk>