aboutsummaryrefslogtreecommitdiff
path: root/lang/python26/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python26/Makefile')
-rw-r--r--lang/python26/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 9aa26c7460b5..e77ea3a77044 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -62,7 +62,6 @@ OPTIONS= THREADS "Enable thread support" on \
.if defined(WITH_SEM)
.if ${OSVERSION} >= 701106
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-setup.py
SEM_MSG= ""
.else
IGNORE= POSIX semaphore support only works in FreeBSD 7-STABLE and later
@@ -182,6 +181,13 @@ pre-patch:
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
+post-patch:
+.if defined(WITH_SEM)
+.if ${OSVERSION} >= 701106
+ @cd ${WRKSRC} && ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-setup.py
+.endif
+.endif
+
post-configure:
${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${SHARED_WRKSRC} -xf -
${LN} -sf ${PYTHON_WRKSRC}/Lib ${WRKSRC}/Lib