aboutsummaryrefslogtreecommitdiff
path: root/lang/python27
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python27')
-rw-r--r--lang/python27/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index fb4b92fc0f43..5f8fb7e25a5b 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -58,6 +58,17 @@ OPTIONS_SINGLE_UCS= UCS2 UCS4
NLS_DESC= Enable Gettext support for the locale module
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
+#LDFLAGS+= "-L${LOCALBASE}/lib"
+#CFLAGS+= "-I${LOCALBASE}/include"
+.else
+CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
+.endif
+
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MSEM}
@@ -80,15 +91,6 @@ PLIST_SUB+= IF_DEFAULT=""
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
-.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
-# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
-#LDFLAGS+= "-L${LOCALBASE}/lib"
-#CFLAGS+= "-I${LOCALBASE}/include"
-.else
-CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
-.endif
-
.if ${PORT_OPTIONS:MTHREADS}
PLIST_SUB+= THREADS=""
.if ${PORT_OPTIONS:MPTH}