aboutsummaryrefslogtreecommitdiff
path: root/lang/python31/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python31/Makefile')
-rw-r--r--lang/python31/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index fe715b119522..3cc135b675b2 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -32,9 +32,11 @@ MAN1= python.1
SETUP_FILE= Setup
#
-# Support for Tk is compiled in by default.
+# Support for Tk is compiled in by default only if X11 is installed.
#
+.if exists(${X11_BASE})
WITH_TK?= yes
+.endif
.if defined(WITH_TK) && $(WITH_TK) == yes
TK_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
SETUP_LOCAL= Setup.tk
@@ -104,6 +106,8 @@ pre-install:
post-install:
strip ${PREFIX}/bin/python
@${MKDIR} ${PREFIX}/share/doc/python
+ @${MKDIR} ${PREFIX}/share/emacs/site-lisp
+ ${INSTALL_DATA} ${WRKSRC}/Misc/python-mode.el ${PREFIX}/share/emacs/site-lisp
${INSTALL_DATA} ${WRKSRC}/Misc/COPYRIGHT ${PREFIX}/share/doc/python
@${MKDIR} ${PREFIX}/lib/python1.5/site-packages
.if defined(WITH_TOOLS) && ${WITH_TOOLS} == yes