aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby_static/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ruby_static/Makefile')
-rw-r--r--lang/ruby_static/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/ruby_static/Makefile b/lang/ruby_static/Makefile
index 3c1679702af1..be92b2620aae 100644
--- a/lang/ruby_static/Makefile
+++ b/lang/ruby_static/Makefile
@@ -19,7 +19,8 @@ USE_RUBY= yes
USE_AUTOCONF= yes
-# Beware, we can't statically link the gdbm module because gdbm is GPL'ed.
+# Beware, you can't statically link Ruby with GPL'ed libraries,
+# which means you can't link such modules as ruby-gdbm within.
EXT_PORTS= archivers/ruby-zlib \
devel/ruby-strscan \
sysutils/ruby-syslog
@@ -63,7 +64,7 @@ do-extract:
for x in *; do [ -d $$x ] && echo $$x >> Setup; done)
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${RUBY_NAME} ${RUBY}${_RUBY_SUFFIX}_s
- ${LN} -fs ${RUBY}${_RUBY_SUFFIX}_s ${RUBY}_s
+ ${INSTALL_PROGRAM} ${WRKSRC}/${RUBY_NAME} ${RUBY_WITH_SUFFIX}_s
+ ${LN} -fs ${RUBY_WITH_SUFFIX}_s ${RUBY_WITHOUT_SUFFIX}_s
.include <bsd.port.post.mk>