aboutsummaryrefslogtreecommitdiff
path: root/lang/rust-bootstrap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/rust-bootstrap/Makefile')
-rw-r--r--lang/rust-bootstrap/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/lang/rust-bootstrap/Makefile b/lang/rust-bootstrap/Makefile
index d28f413f2059..3ec780c9b8b6 100644
--- a/lang/rust-bootstrap/Makefile
+++ b/lang/rust-bootstrap/Makefile
@@ -5,7 +5,7 @@
# for the next lang/rust update.
PORTNAME= rust
PORTVERSION= 1.50.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= https://static.rust-lang.org/dist/:rust \
LOCAL/mikael:armbase \
@@ -39,6 +39,7 @@ FLAVORS= aarch64 amd64 armv6 armv7 i386 powerpc64_elfv1 powerpc64_elfv2 powerpc6
FLAVOR?= ${FLAVORS:[1]}
aarch64_PKGNAMEPREFIX= aarch64-
+aarch64_BUILD_DEPENDS= llvm90>0:devel/llvm90
amd64_PKGNAMEPREFIX= amd64-
armv6_PKGNAMEPREFIX= armv6-
armv7_PKGNAMEPREFIX= armv7-
@@ -54,6 +55,10 @@ USE_GCC= 9:build
.endif
# for openssl-src crate
USE_PERL5= build
+.if ${FLAVOR} == aarch64
+CC= clang90
+CXX= clang++90
+.endif
PATCHDIR= ${.CURDIR}/../rust/files
# Resulting packages are not specific to amd64
NO_ARCH= yes