aboutsummaryrefslogtreecommitdiff
path: root/lang/stklos
diff options
context:
space:
mode:
Diffstat (limited to 'lang/stklos')
-rw-r--r--lang/stklos/Makefile11
-rw-r--r--lang/stklos/distinfo4
-rw-r--r--lang/stklos/pkg-plist2
3 files changed, 13 insertions, 4 deletions
diff --git a/lang/stklos/Makefile b/lang/stklos/Makefile
index 07011c909f31..fd5c4076aeef 100644
--- a/lang/stklos/Makefile
+++ b/lang/stklos/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= stklos
-PORTVERSION= 1.01
+PORTVERSION= 1.10
CATEGORIES= lang scheme
MASTER_SITES= http://www.stklos.net/download/ \
ftp://kaolin.essi.fr/pub/STklos/
@@ -17,7 +17,7 @@ COMMENT= The successor of the STk Scheme interpreter
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
pcre.0:${PORTSDIR}/devel/pcre \
ffi.5:${PORTSDIR}/devel/libffi \
- gc.1:${PORTSDIR}/devel/boehm-gc-threaded
+ gc-threaded.1:${PORTSDIR}/devel/boehm-gc-threaded
ONLY_FOR_ARCHS= i386 amd64
@@ -47,6 +47,9 @@ post-patch:
-e 's|-@VERSION@||' \
-e 's|^man_MANS = |man_MANS = stklos-pkg.1 |' \
${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e 's|; make|; $$(MAKE)|' \
+ ${WRKSRC}/doc/Makefile.in ${WRKSRC}/doc/Makefile.am \
+ ${WRKSRC}/lib/Makefile.in ${WRKSRC}/lib/Makefile.am
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -E -e 's/^(install-data-am:).*/\1 install-man install-schemeDATA/' \
@@ -54,4 +57,8 @@ post-patch:
${WRKSRC}/doc/Makefile.in
.endif
+regression-test: build
+ (cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} \
+ ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test)
+
.include <bsd.port.post.mk>
diff --git a/lang/stklos/distinfo b/lang/stklos/distinfo
index 23a807471d47..7d8f0e343281 100644
--- a/lang/stklos/distinfo
+++ b/lang/stklos/distinfo
@@ -1,2 +1,2 @@
-SHA256 (stklos-1.01.tar.gz) = 4917eb6151376959ceff1bfb7e9ce9e8df5d4634898f0633d16780e347aad18a
-SIZE (stklos-1.01.tar.gz) = 5865061
+SHA256 (stklos-1.10.tar.gz) = 215e6e6ffcf7751be5f0c114f83286f99e556e089ca1b0ee66f54dd1be080de4
+SIZE (stklos-1.10.tar.gz) = 6097807
diff --git a/lang/stklos/pkg-plist b/lang/stklos/pkg-plist
index 3a86c315df36..43ab392c5506 100644
--- a/lang/stklos/pkg-plist
+++ b/lang/stklos/pkg-plist
@@ -78,6 +78,7 @@ include/stklos/stklosconf.h
%%DATADIR%%/%%VERSION%%/pp.stk
%%DATADIR%%/%%VERSION%%/process.stk
%%DATADIR%%/%%VERSION%%/r5rs.stk
+%%DATADIR%%/%%VERSION%%/r7rs.stk
%%DATADIR%%/%%VERSION%%/readline.stk
%%DATADIR%%/%%VERSION%%/recette.ostk
%%DATADIR%%/%%VERSION%%/recette.stk
@@ -143,6 +144,7 @@ include/stklos/stklosconf.h
%%DATADIR%%/%%VERSION%%/srfi-9.stk
%%DATADIR%%/%%VERSION%%/srfi-96.ostk
%%DATADIR%%/%%VERSION%%/srfi-96.stk
+%%DATADIR%%/%%VERSION%%/str.stk
%%DATADIR%%/%%VERSION%%/struct.stk
%%DATADIR%%/%%VERSION%%/tar.ostk
%%DATADIR%%/%%VERSION%%/tar.stk