aboutsummaryrefslogtreecommitdiff
path: root/lang/tcl-manual/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/tcl-manual/Makefile')
-rw-r--r--lang/tcl-manual/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/lang/tcl-manual/Makefile b/lang/tcl-manual/Makefile
new file mode 100644
index 000000000000..9269533eb912
--- /dev/null
+++ b/lang/tcl-manual/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: tcl-manual
+# Date created: 13 December 2001
+# Whom: Edwin Groothuis (edwin@mavetju.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcl-manual
+PORTVERSION= 2001.12.19
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= tcl
+DISTFILES= tcl8.3.4.html.tar.gz tcl8.4a3.html.tar.gz
+
+MAINTAINER= edwin@mavetju.org
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+post-patch:
+ @${RM} ${WRKDIR}/tcl8.3.4/html/UserCmd/*.orig
+ @${RM} ${WRKDIR}/tcl8.4a3/html/UserCmd/*.orig
+ @${PERL} -pi -e 's|tcl\.h|tcl8.3/tcl.h|g' \
+ ${WRKDIR}/tcl8.3.4/html/TclLib/*
+ @${PERL} -pi -e 's|tk\.h|tk8.3/tk.h|g' ${WRKDIR}/tcl8.3.4/html/TkLib/*
+ @${PERL} -pi -e 's|tcl\.h|tcl8.4/tcl.h|g' \
+ ${WRKDIR}/tcl8.4a3/html/TclLib/*
+ @${PERL} -pi -e 's|tk\.h|tk8.4/tk.h|g' ${WRKDIR}/tcl8.4a3/html/TkLib/*
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/doc/tcl83
+ ${MKDIR} ${PREFIX}/share/doc/tcl84
+ ${CP} -R ${WRKDIR}/tcl8.4a3/html/* ${PREFIX}/share/doc/tcl84
+ ${CP} -R ${WRKDIR}/tcl8.3.4/html/* ${PREFIX}/share/doc/tcl83
+
+.include <bsd.port.mk>