aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/csharp-mode.el/Makefile22
-rw-r--r--lang/csharp-mode.el/distinfo5
-rw-r--r--lang/csharp-mode.el/pkg-descr2
3 files changed, 10 insertions, 19 deletions
diff --git a/lang/csharp-mode.el/Makefile b/lang/csharp-mode.el/Makefile
index 7f0b4aaa46d4..fe397320bcb6 100644
--- a/lang/csharp-mode.el/Makefile
+++ b/lang/csharp-mode.el/Makefile
@@ -2,36 +2,26 @@
# $FreeBSD$
PORTNAME= csharp-mode.el
-PORTVERSION= 0.8.5
-PORTREVISION= 9
+PORTVERSION= 0.9.0
+DISTVERSIONPREFIX= v
CATEGORIES= lang elisp
-MASTER_SITES= GOOGLE_CODE
-DISTNAME= ${PORTNAME:S|.el$||}-${PORTVERSION}.el
-EXTRACT_SUFX= # none
MAINTAINER= mva@FreeBSD.org
COMMENT= Emacs/XEmacs major mode for editing C\# source code
LICENSE= GPLv2
-BROKEN= Unfetchable (google code has gone away)
+USE_GITHUB= yes
+GH_ACCOUNT= josteink
+GH_PROJECT= csharp-mode
-PROJECTHOST= csharpmode
-NO_WRKSUBDIR= yes
NO_BUILD= yes
-EXTRACT_CMD= ${CP}
-EXTRACT_BEFORE_ARGS= # none
-EXTRACT_AFTER_ARGS= .
-
USE_EMACS= yes
PLIST_FILES= ${EMACS_SITE_LISPDIR}/csharp-mode.el
-post-patch:
- @${MV} ${WRKSRC}/csharp-mode-${PORTVERSION}.el ${WRKSRC}/csharp-mode.el
-
do-install:
- ${INSTALL_DATA} ${WRKSRC}/csharp-mode.* \
+ ${INSTALL_DATA} ${WRKSRC}/csharp-mode.el \
${STAGEDIR}${PREFIX}/${EMACS_SITE_LISPDIR}
.include <bsd.port.mk>
diff --git a/lang/csharp-mode.el/distinfo b/lang/csharp-mode.el/distinfo
index 7b43f711940f..232617607e89 100644
--- a/lang/csharp-mode.el/distinfo
+++ b/lang/csharp-mode.el/distinfo
@@ -1,2 +1,3 @@
-SHA256 (csharp-mode-0.8.5.el) = f91081c916781453c87660ef385e8b33dbaea854b41756580707f3f79752c7ce
-SIZE (csharp-mode-0.8.5.el) = 225700
+TIMESTAMP = 1479037651
+SHA256 (josteink-csharp-mode-v0.9.0_GH0.tar.gz) = 4232fe0fc4528be543ca1e338ce3e839814f2a5b43e480c16b7b4f1ea1bca3c5
+SIZE (josteink-csharp-mode-v0.9.0_GH0.tar.gz) = 50453
diff --git a/lang/csharp-mode.el/pkg-descr b/lang/csharp-mode.el/pkg-descr
index 73382a74d7df..42a30bbf76ef 100644
--- a/lang/csharp-mode.el/pkg-descr
+++ b/lang/csharp-mode.el/pkg-descr
@@ -8,4 +8,4 @@ decided to follow the rules and create one that required no patching or
modification to the core cc-mode engine (which is a good thing). So, this is
the C# mode.
-WWW: http://code.google.com/p/csharpmode/
+WWW: https://github.com/josteink/csharp-mode