aboutsummaryrefslogtreecommitdiff
path: root/mail/mail2sms/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/mail2sms/Makefile')
-rw-r--r--mail/mail2sms/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/mail/mail2sms/Makefile b/mail/mail2sms/Makefile
new file mode 100644
index 000000000000..ccfaa72023ca
--- /dev/null
+++ b/mail/mail2sms/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: mail2sms
+# Date created: 2003-04-16
+# Whom: Gerhard Gonter <g.gonter@ieee.org>
+#
+# $FreeBSD$
+
+PORTNAME= mail2sms
+PORTVERSION= 1.3.5
+CATEGORIES= mail
+MASTER_SITES= http://www.contactor.se/~dast/stuff/
+DISTNAME= mail2sms-${PORTVERSION}
+
+MAINTAINER= g.gonter@ieee.org
+COMMENT= Mail to SMS converter
+
+GNU_CONFIGURE= yes
+
+MAN1= mail2sms.1
+MAN5= mail2sms.5
+
+post-patch:
+ ${CP} ${WRKSRC}/mail2sms.4 ${WRKSRC}/mail2sms.5
+ ${SED} -i.bak -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/mail2sms.5
+ ${SED} -i.bak -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/main.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mail2sms ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/${MAN5} ${PREFIX}/man/man5/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/mail2sms
+ ${INSTALL_MAN} ${WRKSRC}/README ${WRKSRC}/REGEX ${WRKSRC}/example.conf \
+ ${PREFIX}/share/doc/mail2sms
+.endif
+
+.include <bsd.port.mk>