aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Mail-SPF/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/p5-Mail-SPF/Makefile')
-rw-r--r--mail/p5-Mail-SPF/Makefile34
1 files changed, 29 insertions, 5 deletions
diff --git a/mail/p5-Mail-SPF/Makefile b/mail/p5-Mail-SPF/Makefile
index 47d16f6626a8..62d296514c32 100644
--- a/mail/p5-Mail-SPF/Makefile
+++ b/mail/p5-Mail-SPF/Makefile
@@ -3,13 +3,13 @@
PORTNAME= Mail-SPF
PORTVERSION= 2.007
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
DISTNAME= ${PORTNAME}-v${PORTVERSION}
-MAINTAINER= gmc@sonologic.nl
+MAINTAINER= ports@FreeBSD.org
COMMENT= Reference implementation of the RFC 4408 SPF protocol
RUN_DEPENDS= p5-Net-DNS-Resolver-Programmable>=0.002.1:${PORTSDIR}/dns/p5-Net-DNS-Resolver-Programmable \
@@ -20,12 +20,11 @@ RUN_DEPENDS= p5-Net-DNS-Resolver-Programmable>=0.002.1:${PORTSDIR}/dns/p5-Net-DN
p5-URI>=1.13:${PORTSDIR}/net/p5-URI
BUILD_DEPENDS:= ${RUN_DEPENDS}
-CONFLICTS= libspf2-[0-9]* p5-Mail-SPF-Query-[0-9]*
+CONFLICTS= p5-Mail-SPF-Query-[0-9]*
PERL_MODBUILD= yes
CONFIGURE_ARGS= --install_path sbin=${PREFIX}/sbin
-MAN1= spfquery.1
MAN3= Mail::SPF.3 Mail::SPF::Mech::PTR.3 Mail::SPF::Mech.3 \
Mail::SPF::SenderIPAddrMech.3 Mail::SPF::MacroString.3 \
Mail::SPF::Mech::IP4.3 Mail::SPF::Mech::A.3 \
@@ -37,13 +36,38 @@ MAN3= Mail::SPF.3 Mail::SPF::Mech::PTR.3 Mail::SPF::Mech.3 \
Mail::SPF::Base.3 Mail::SPF::Mech::All.3 Mail::SPF::Term.3 \
Mail::SPF::v1::Record.3 Mail::SPF::Mech::Exists.3
+OPTIONS_DEFINE= SPFQUERY SPFQUERY_SUFFIX DOCS
+SPFQUERY_DESC= Install spfquery command-line tool
+SPFQUERY_SUFFIX_DESC=Add .pl suffix to spfquery
+OPTIONS_DEFAULT=SPFQUERY SPFQUERY_SUFFIX
+
.include <bsd.port.pre.mk>
DOCSDIR= ${PREFIX}/share/doc/p5-Mail-SPF
DOCS= CHANGES INSTALL LICENSE README TODO
+.if ${PORT_OPTIONS:MSPFQUERY}
+PLIST_SUB+= SPFQUERY=""
+
+.if ${PORT_OPTIONS:MSPFQUERY_SUFFIX}
+PLIST_SUB+= SPFQUERY_SUFFIX=".pl"
+MAN1+= spfquery.pl.1
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-spfquery-suffix
+post-extract:
+ ${MV} ${WRKSRC}/bin/spfquery ${WRKSRC}/bin/spfquery.pl
+.else
+PLIST_SUB+= SPFQUERY_SUFFIX=""
+MAN1+= spfquery.1
+CONFLICTS+= libspf2-[0-9]*
+.endif
+
+.else
+PLIST_SUB+= SPFQUERY="@comment "
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-no-spfquery
+.endif
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.endif