aboutsummaryrefslogtreecommitdiff
path: root/mail/pop3vscan/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/pop3vscan/Makefile')
-rw-r--r--mail/pop3vscan/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/mail/pop3vscan/Makefile b/mail/pop3vscan/Makefile
index dce6607ba0ee..0011eb6a8545 100644
--- a/mail/pop3vscan/Makefile
+++ b/mail/pop3vscan/Makefile
@@ -18,13 +18,14 @@ COMMENT= A transparent POP3-Proxy with virus-scanning capabilities
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
.if !defined(WITHOUT_UVSCAN)
-RUN_DEPENDS= uvscan:${PORTSDIR}/security/vscan
+RUN_DEPENDS+= uvscan:${PORTSDIR}/security/vscan
.endif
USE_REINPLACE= yes
USE_GMAKE= yes
USE_GETOPT_LONG=yes
MAKE_ENV= _LDFLAGS="${LDFLAGS}"
+SCRIPTS_ENV= PKG_PREFIX=${PREFIX} NONEXISTENT=${NONEXISTENT} PASSWD=/etc/passwd
pre-fetch:
.if !defined(WITHOUT_UVSCAN)
@@ -50,7 +51,7 @@ do-install:
${INSTALL_SCRIPT} ${FILESDIR}/pop3vscan.sh ${PREFIX}/etc/rc.d/
post-install:
- @${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${SED} -e 's,PREFIX,${PREFIX},g' ${PKGMESSAGE}
.include <bsd.port.mk>