aboutsummaryrefslogtreecommitdiff
path: root/math/asymptote/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/asymptote/Makefile')
-rw-r--r--math/asymptote/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 8ed09cd34cc7..0caf07e94788 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -3,7 +3,7 @@
PORTNAME= asymptote
PORTVERSION= 2.67
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -18,16 +18,16 @@ ONLY_FOR_ARCHS= amd64 i386
LIB_DEPENDS= libcurl.so:ftp/curl \
libsigsegv.so:devel/libsigsegv
-RUN_DEPENDS= rsvg-convert:graphics/librsvg2 \
- ${PYTHON_PKGNAMEPREFIX}cson>=0.8:devel/py-cson@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cson>=0.8:devel/py-cson@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}qt5-svg>0:graphics/py-qt5-svg@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}qt5-widgets>0:x11-toolkits/py-qt5-widgets@${PY_FLAVOR} \
${PY_PILLOW}
-USES= compiler:c++14-lang gettext-runtime ghostscript gl gmake ncurses perl5 python:3.6+ \
+USES= compiler:c++14-lang gettext-runtime ghostscript gl gmake gnome ncurses perl5 python:3.6+ \
shebangfix tar:tgz
SHEBANG_FILES= GUI/*.py
USE_GL= gl glu glut
+USE_GNOME= librsvg2:run
USE_PERL5= build
USE_TEX= dvipsk formats