aboutsummaryrefslogtreecommitdiff
path: root/math/atlas/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/atlas/Makefile')
-rw-r--r--math/atlas/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index fd1303f720f7..2d15ddfb9914 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -42,11 +42,11 @@ post-patch:
@${REINPLACE_CMD} -e 's+%%PTHREAD_CFLAGS%%+${PTHREAD_CFLAGS}+g' \
-e 's+%%PTHREAD_LIBS%%+${PTHREAD_LIBS}+g' \
${WRKSRC}/config.c
-.if (${ARCH} == "alpha")
+.if (${MACHINE_ARCH} == "alpha")
@(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/alpha-patch)
.endif
-.if ${ARCH} == "sparc64"
+.if ${MACHINE_ARCH} == "sparc64"
PICFLAG?= -fPIC
.else
PICFLAG?= -fpic