aboutsummaryrefslogtreecommitdiff
path: root/math/blaze/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/blaze/Makefile')
-rw-r--r--math/blaze/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/math/blaze/Makefile b/math/blaze/Makefile
new file mode 100644
index 000000000000..88cf0383a1f6
--- /dev/null
+++ b/math/blaze/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= blaze
+DISTVERSION= 3.3-430
+CATEGORIES= math
+MASTER_SITES= https://bitbucket.org/${BB_ACCOUNT}/${BB_PROJECT}/get/${BB_COMMIT}.tar.gz?dummy=/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ math library for dense and sparse arithmetic
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= boost-libs>0:devel/boost-libs \
+ openblas>0:math/openblas \
+ openmp>0:devel/openmp
+RUN_DEPENDS= boost-libs>0:devel/boost-libs \
+ openblas>0:math/openblas \
+ openmp>0:devel/openmp
+
+USES= cmake:outsource compiler:c++14-lang fortran localbase:ldflags
+NO_ARCH= yes
+
+BB_ACCOUNT= ${PORTNAME}-lib
+BB_PROJECT= ${PORTNAME}
+BB_COMMIT= ea158fdf70ef
+
+WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${BB_PROJECT}-${BB_COMMIT}
+
+.include <bsd.port.mk>