aboutsummaryrefslogtreecommitdiff
path: root/math/dune-common/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/dune-common/Makefile')
-rw-r--r--math/dune-common/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/math/dune-common/Makefile b/math/dune-common/Makefile
index ee64c42dad1f..d198f2dc8bbe 100644
--- a/math/dune-common/Makefile
+++ b/math/dune-common/Makefile
@@ -2,8 +2,7 @@
PORTNAME= dune-common
DISTVERSIONPREFIX= v
-DISTVERSION= 2.7.0
-PORTREVISION= 4
+DISTVERSION= 2.7.1
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -18,26 +17,31 @@ LIB_DEPENDS= libopenblas.so:math/openblas \
libtbb.so:devel/tbb
USES= cmake compiler:c++17-lang fortran pkgconfig python shebangfix
-SHEBANG_FILES= bin/dune-ctest
+SHEBANG_FILES= bin/dune-ctest cmake/scripts/extract_cmake_data.py
USE_GITLAB= yes
USE_LDCONFIG= yes
GL_SITE= https://gitlab.dune-project.org
GL_ACCOUNT= core
-GL_COMMIT= c5321673af09725a411bdd81aa2be5cfaf8bf9a6
+GL_COMMIT= aa689abba532f40db8f5663fa379ea77211c1953
CMAKE_ON= BUILD_SHARED_LIBS
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS DOXYGEN
OPTIONS_SUB= yes
DOCS_CMAKE_BOOL= FREEBSD_INSTALL_DOCS
-DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
- latex:print/tex-formats \
+DOCS_BUILD_DEPENDS= latex:print/tex-formats \
sphinx-build:textproc/py-sphinx
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
+DOXYGEN_IMPLIES= DOCS
+
PORTDOCS= *
+post-install:
+ @${RM} ${STAGEDIR}${PREFIX}/share/dune/cmake/scripts/run-in-dune-env.sh.in # https://gitlab.dune-project.org/core/dune-common/-/issues/229
+
post-stage-DOCS-on: # https://gitlab.dune-project.org/core/dune-common/issues/191
@${RMDIR} ${STAGEDIR}${DOCSDIR}/comm