aboutsummaryrefslogtreecommitdiff
path: root/math/dune-geometry/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/dune-geometry/Makefile')
-rw-r--r--math/dune-geometry/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/math/dune-geometry/Makefile b/math/dune-geometry/Makefile
index 58f0ac5689c0..4b2aece4f01a 100644
--- a/math/dune-geometry/Makefile
+++ b/math/dune-geometry/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dune-geometry
DISTVERSIONPREFIX= v
DISTVERSION= 2.7.1
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -15,7 +16,7 @@ BUILD_DEPENDS= openmpi>0:net/openmpi \
vc>0:devel/vc
LIB_DEPENDS= libdunecommon.so:math/dune-common \
libopenblas.so:math/openblas \
- libtbb.so:devel/tbb
+ libtbb.so:devel/onetbb
USES= cmake compiler:c++17-lang fortran pkgconfig python
USE_GITLAB= yes
@@ -26,6 +27,7 @@ GL_ACCOUNT= core
GL_COMMIT= 9d56be3e286bc761dd5d453332a8d793eff00cbe
CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_ARGS= -DTBB_INCLUDE_DIR=${LOCALBASE}/include -DTBB_LIBRARIES=${LOCALBASE}/lib/libtbb.so
OPTIONS_DEFINE= DOCS
OPTIONS_SUB= yes