aboutsummaryrefslogtreecommitdiff
path: root/math/ocaml-ocamlgraph/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/ocaml-ocamlgraph/Makefile')
-rw-r--r--math/ocaml-ocamlgraph/Makefile20
1 files changed, 17 insertions, 3 deletions
diff --git a/math/ocaml-ocamlgraph/Makefile b/math/ocaml-ocamlgraph/Makefile
index 85992ec656de..793c2881685c 100644
--- a/math/ocaml-ocamlgraph/Makefile
+++ b/math/ocaml-ocamlgraph/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ocamlgraph
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= math
MASTER_SITES= http://ocamlgraph.lri.fr/download/
PKGNAMEPREFIX= ocaml-
@@ -14,10 +14,13 @@ PKGNAMEPREFIX= ocaml-
MAINTAINER= johans@stack.nl
COMMENT= Graph manipulation library for OCaml
+OPTIONS= GUI "Include user programs: viewer and editor" off
+
USE_OCAML= yes
+USE_OCAML_FINDLIB= yes
USE_OCAML_LDCONFIG= yes
USE_GMAKE= yes
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
PLIST_SUB+= OCAML_LIBDIR="${OCAML_LIBDIR}"
@@ -26,6 +29,17 @@ ALL_TARGET= all
ALL_TARGET+= doc
PORTDOCS= *
+.include <bsd.port.pre.mk>
+
+.ifdef WITH_GUI
+BUILD_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
+RUN_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
+PLIST_SUB+= GUI=""
+.else
+CONFIGURE_ARGS+= LABLGTK2=no
+PLIST_SUB+= GUI="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/VIEWER_DIR. doc/d' ${WRKSRC}/Makefile.in
@@ -34,4 +48,4 @@ post-install:
cd ${WRKSRC}/doc; ${INSTALL_DATA} * ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>