aboutsummaryrefslogtreecommitdiff
path: root/math/permlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/permlib/Makefile')
-rw-r--r--math/permlib/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/math/permlib/Makefile b/math/permlib/Makefile
new file mode 100644
index 000000000000..42201be8d7e2
--- /dev/null
+++ b/math/permlib/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= permlib
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.9
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ header-only library for permutation computations
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= boost-libs>0:devel/boost-libs
+
+USE_GITHUB= yes
+GH_ACCOUNT= tremlin
+GH_PROJECT= PermLib
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+do-install:
+ cd ${WRKSRC} && ${COPYTREE_SHARE} include ${STAGEDIR}${PREFIX}
+ ${FIND} ${STAGEDIR}${PREFIX}/include -name "*.orig" -delete
+
+.include <bsd.port.mk>