aboutsummaryrefslogtreecommitdiff
path: root/math/polymake/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/polymake/Makefile')
-rw-r--r--math/polymake/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/math/polymake/Makefile b/math/polymake/Makefile
index 56688d42e858..4bac642d221b 100644
--- a/math/polymake/Makefile
+++ b/math/polymake/Makefile
@@ -7,7 +7,7 @@
PORTNAME= polymake
PORTVERSION= 2.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= ftp://ftp.math.tu-berlin.de/pub/combi/polymake/
@@ -22,7 +22,6 @@ LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
USE_GMAKE= yes
USE_BZIP2= yes
USE_PERL5= 5.8.1+
-USE_GCC= 3.4
HAS_CONFIGURE= yes
INSTALL_TARGET= install install-devel
@@ -36,6 +35,9 @@ PLIST= ${WRKDIR}/pkg-plist
BROKEN= Does not build with perl >= 5.10
.endif
+pre-configure:
+ @${REINPLACE_CMD} -e 's|return "$$CXX seems not to be any|\#|' ${WRKSRC}/support/configure.pl
+
do-configure:
cd ${WRKSRC}; \
${RM} -f build*/conf.make; \
@@ -52,7 +54,7 @@ do-configure:
${ECHO_CMD} PerlExe='${PERL}'; \
${ECHO_CMD} Arch=; \
${ECHO_CMD} ProcessDep=none; \
- } | ${GMAKE} configure
+ } | ${GMAKE} ${MAKE_ENV} LD=${LD} configure
pre-install:
${RM} -f `find ${WRKSRC} -name '*.orig'`