aboutsummaryrefslogtreecommitdiff
path: root/math/qwtplot3d-qt4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/qwtplot3d-qt4/Makefile')
-rw-r--r--math/qwtplot3d-qt4/Makefile40
1 files changed, 0 insertions, 40 deletions
diff --git a/math/qwtplot3d-qt4/Makefile b/math/qwtplot3d-qt4/Makefile
deleted file mode 100644
index 98fa5be3c3cb..000000000000
--- a/math/qwtplot3d-qt4/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: qwtplot3d
-# Date created: Aug 30, 2004
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= qwtplot3d
-PORTVERSION= 0.2.6
-PORTREVISION= 1
-CATEGORIES= math
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-EXTRACT_SUFX= .tgz
-
-MAINTAINER= makc@issp.ac.ru
-COMMENT= A 3D plotting widget for scientific data and mathematical expressions
-
-BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
-
-USE_QT_VER= 3
-WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKE_ENV= QTDIR=${QT_PREFIX}
-USE_LDCONFIG= yes
-
-pre-build:
- @cd ${WRKSRC}; qmake -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ ${PORTNAME}.pro
-
-do-install:
- ${CP} ${WRKSRC}/include/* ${PREFIX}/include
- ${INSTALL_DATA} ${WRKSRC}/lib/libqwtplot3d.so.${PORTVERSION} ${PREFIX}/lib
- ${LN} -fs ${PREFIX}/lib/libqwtplot3d.so.${PORTVERSION} ${PREFIX}/lib/libqwtplot3d.so.0
- ${LN} -fs ${PREFIX}/lib/libqwtplot3d.so.${PORTVERSION} ${PREFIX}/lib/libqwtplot3d.so
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${EXAMPLESDIR}
- (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
-.endif
-
-.include <bsd.port.mk>