aboutsummaryrefslogtreecommitdiff
path: root/math/scigraphica/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/scigraphica/Makefile')
-rw-r--r--math/scigraphica/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/math/scigraphica/Makefile b/math/scigraphica/Makefile
index 644100ffc465..115dc661cf18 100644
--- a/math/scigraphica/Makefile
+++ b/math/scigraphica/Makefile
@@ -32,6 +32,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@@ -43,4 +49,4 @@ post-install:
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/share/gnome/scigraphica
@${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/share/gnome/scigraphica
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>