aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/convertall/Makefile3
-rw-r--r--math/emc2/Makefile3
-rw-r--r--math/fityk/Makefile3
-rw-r--r--math/gri/Makefile3
-rw-r--r--math/jags/Makefile3
-rw-r--r--math/jakarta-commons-math3/Makefile3
-rw-r--r--math/jts/Makefile3
-rw-r--r--math/libqalculate/Makefile3
-rw-r--r--math/petsc/Makefile3
-rw-r--r--math/pure-mpfr/Makefile2
-rw-r--r--math/pure-rational/Makefile2
-rw-r--r--math/snns/Makefile3
12 files changed, 34 insertions, 0 deletions
diff --git a/math/convertall/Makefile b/math/convertall/Makefile
index a02ba1fe0d18..b257fb217a04 100644
--- a/math/convertall/Makefile
+++ b/math/convertall/Makefile
@@ -24,6 +24,9 @@ DESKTOP_ENTRIES="ConvertAll" "Unit converter" "${DATADIR}/icons/${PORTNAME}.svg"
"${PORTNAME}" "Utility;Calculator;" true
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/math/emc2/Makefile b/math/emc2/Makefile
index f4445ef91ffd..5ae4e36b0978 100644
--- a/math/emc2/Makefile
+++ b/math/emc2/Makefile
@@ -35,6 +35,9 @@ PORTEXAMPLES= *
PLIST_FILES= bin/emc2 bin/prf_f3d
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/emc2 ${PREFIX}/bin
diff --git a/math/fityk/Makefile b/math/fityk/Makefile
index 9d1f8cf84484..f9a62e7ae03b 100644
--- a/math/fityk/Makefile
+++ b/math/fityk/Makefile
@@ -43,6 +43,9 @@ LDFLAGS+= -L${WRKDIR}/${XYLIB_DISTNAME}/xylib/.libs \
XYLIB_DISTNAME= xylib-1.1
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/math/gri/Makefile b/math/gri/Makefile
index 867be67499b1..0e07761ab575 100644
--- a/math/gri/Makefile
+++ b/math/gri/Makefile
@@ -32,6 +32,9 @@ PLIST_FILES= bin/gri bin/gri_merge bin/gri_unpage \
PLIST_DIRS= %%DATADIR%%
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS} || ${PORT_OPTIONS:MEXAMPLES}
diff --git a/math/jags/Makefile b/math/jags/Makefile
index 4bf8c1929a56..aad51c1624dd 100644
--- a/math/jags/Makefile
+++ b/math/jags/Makefile
@@ -33,6 +33,9 @@ PLIST_SUB= MODULEVERSION=${S}
S= ${PORTVERSION:C|\..*||}
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS} || make(makesum)
diff --git a/math/jakarta-commons-math3/Makefile b/math/jakarta-commons-math3/Makefile
index 48202478cf37..79fec05522ae 100644
--- a/math/jakarta-commons-math3/Makefile
+++ b/math/jakarta-commons-math3/Makefile
@@ -42,6 +42,9 @@ DESTJARFILE= ${PORTNAME}.jar
PLIST_FILES+= %%JAVAJARDIR%%/${DESTJARFILE}
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/math/jts/Makefile b/math/jts/Makefile
index 67f3d67da6d5..a5c493058d29 100644
--- a/math/jts/Makefile
+++ b/math/jts/Makefile
@@ -22,6 +22,9 @@ VER= ${PORTVERSION:L}
JARFILES= JTS_Test acme jts-${VER}
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
index 56259fd2cc60..d96729e963f2 100644
--- a/math/libqalculate/Makefile
+++ b/math/libqalculate/Makefile
@@ -19,6 +19,9 @@ USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
index 6de505cd7a2e..dac39d95144c 100644
--- a/math/petsc/Makefile
+++ b/math/petsc/Makefile
@@ -56,6 +56,9 @@ CONFIGURE_ARGS+= --with-umfpack-include="${LOCALBASE}/include/suitesparse" \
.endif
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/math/pure-mpfr/Makefile b/math/pure-mpfr/Makefile
index 45bdd2c55cb6..4702c9678bb8 100644
--- a/math/pure-mpfr/Makefile
+++ b/math/pure-mpfr/Makefile
@@ -27,6 +27,8 @@ PORTDOCS= README
PORTEXAMPLES= *
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-install:
diff --git a/math/pure-rational/Makefile b/math/pure-rational/Makefile
index 2f50e20ce1dd..e18a2a81f141 100644
--- a/math/pure-rational/Makefile
+++ b/math/pure-rational/Makefile
@@ -22,6 +22,8 @@ NO_STAGE= yes
PORTDOCS= README
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/math/snns/Makefile b/math/snns/Makefile
index 4f8b68b9dddf..09e09d1ecc5b 100644
--- a/math/snns/Makefile
+++ b/math/snns/Makefile
@@ -20,6 +20,9 @@ CONFIGURE_ARGS= --prefix=${PREFIX}/lib/snns --enable-global \
MAKE_JOBS_UNSAFE= yes
NO_STAGE= yes
+
+OPTIONS_DEFINE= EXAMPLES
+
.include <bsd.port.options.mk>
post-extract: